[Release] In-Game Server/Resource Management ~ Ranks, Kick/Ban, Resource Start/Stop


#7

Alright, I’ll take a look! Thanks


#8

Is there a way to disable the menu, or change the keybind? I use a controller, and every time I hit ‘B’ a menu pops up.


#9

When i try typing in the commands it doesnt do or show anything, i got command processor and the playervar installed properly and resources load no problems


#10

yeah me too if one can help me and cody !!


#11

I am also having this issue.


#12

I reccomend using EssentialMode with the admin plugin


#13

It would be best to use something else until I can get time to work on this. Havn’t had any free time


#14

I don’t completely understand how to install it I dragged the Server management and the player var and the cmd processor into the resources folder and added them to the server yml, it says it loads it but when I get in game, i do /smhelp and nothing happens.


#15

Read the comments above you :confused:


#16

cmd processor has been updated as standalone per mod, no longer uses overriding the chat resource, so this mod is broken for now, needs a fix.


#17

  • Updated Command Proccessor (No need to replace chat anymore)
  • Removed GUID deprecation, uses GetPlayerIdentifiers now
  • Everything should be working as of 5/4/2017
  • Going to make the main post look nicer (maybe)

Update:
Added resource management commands to the trusted permission [/rmstart /rmstop /rmrestart]
giving people in the trusted list the ability to start and stop resources in-game.


#18

I keep receiving this error any time I attempt to use the chat function in the console:

and I am unable to use any command.


#19

Sorry you are having this problem D:

Do you have the required resource enabled as well?
https://forum.fivereborn.com/topic/2609/release-playervar-attach-variables-to-players

Make sure you have this in your AutoStartResources!
- PlayerVar
- ServerManagement

PS: I don’t think the error you see is relevant D: It happens without the resource even loaded.


#20

lol, I forgot to remove the -master after on the folder names. I fixed it.


#21

can someone please help me. add my kik masterjessejames


#22

for the life of me, I can get my guid to show. any help would be appreciated.


#23

Did you load the resource correctly? What happens when you type /smhelp

Also check your server console to see if it has loaded or not

PS when you download from github it has -master make you remove that or include it to the resources!


#24

Yeah, when I type in chat /guid it shows the false flags, but no guid, at the top. So I’m assuming that I installed it right. I’m not sure on the help command, I’ll have to check when I get home. But all the commands work just says I don’t have permission. Cause I can’t get the guid, to put in the rank file.


#25

Do you have steam required on? And logged in to steam? Your guid is a form of your steamid!


#26

Yep, just double checked it when I got home. It’s on and rolling. Ive tried to see if there was other ways to find it, but no such luck.