[Release] Improved Tow Truck Script (Includes 2 custom flatbeds)


#1

A modified version of the tow script by @asser90 with multiple fixes and improvements.

Download: https://github.com/Deziel0495/ImprovedTowTruckScript

Important Note:

Script is designed to work with the regular GTA V FLATBED model, as well as with 2 other modified flatbeds, which I have included. To use this script with other flatbed models the placement values will have to be adjusted, this can be done by following the instructions at the top of the client.lua file.

Credit for the Mule flatbed (flatbed2) goes to TheF3nt0n.
Credit for the Kenworth flatbed (flatbed3) model goes to BrewCityBass.

View image of Flatbed2

View image of Flatbed3

Features:

  • Fixes attach/detach positions on both truck and ground. No more upside down cars when detaching!
  • No more “jello” vehicles that stretch and warp when being towed.
  • Can no longer detach a vehicle while the truck is moving or attach vehicles while they are moving.
  • Vehicles will detach if the truck flips over. (Thanks to @IllusiveTea)
  • Improved notifications.
  • The vehicle that you want to tow needs to be within 12m of your tow truck. (configurable in the client.lua file)
  • Large vehicles cannot be towed. (configurable in the client.lua file)
  • You can have multiple tow trucks registered and have custom x,y,z offsets. (configurable in the client.lua file)

How it works:

  • Using a trainer spawn flatbed, flatbed2 or flatbed3 and get in.
  • When you find a vehicle to tow, get out and walk up to the vehicle.
  • While facing the vehicle type /tow in chat to attach the vehicle to the flatbed.
  • Once at your destination, get out of the truck and type /tow in chat again to detach the vehicle from the flatbed.

Known Issues:

If another player is next to you when the command is entered the vehicle may not attach/detach. Ask them to step away.
The cause of this has been identified (the raycast is detecting the other player instead of the vehicle) and it is being worked on.


[Release] Maibatsu Mule Recovery [Add-On | Liveries | Template]
#2

it works fine but only one proplem tho http://prntscr.com/hhdyu6 the car or anycar does not sit on the flatbed as u can see


#3

That is normal. This is present in both the other towing scripts as well. Some vehicles float above and some sink through the truck.


#4

ok mate thanks just thoght i added it wrong that was all thanks again


#5

Script has been updated to work with a modified flatbed, which I have included. If you do not want this change, do not re-download.


#6

Hello. Can u help me, please?
/tow is not working for me. Resources started. mule5 and towscript. mule5 spawn ok, but command in chat /tow nothing do.


#7

it not working it says dispatch has been notified


#8

No issues in my end, seems to be working fine.

Have you tried restarting the resource and/or clearing the cache for it? Restarting your server? If /tow is going into chat the resource is not being seen by the server. Make sure there are no other players next to you when entering the command.


#9

It looks like you’re using a customchat, someone i know uses that and it is outdated, therefore registercommand isn’t recognised by it. Please update to the FXServer chat in order for this to work without having to edit the chat.


#10

Thanks, but still not work… I have cleaned cache and started fx chat :frowning:


#11

could you make an edit or explain a edit to with with a flatbed trailer ie trflat?


#12

An update was just released, containing a new vehicle, and a lot of new features. For a full change log checkout the main post or the GitHub page.


#13

When I try to /tow a truck to a trailer it flips the car to where the front is coming off the ground


[Release][FX] Towtruck Script V1.2
#14

It shouldn’t even be possible to tow using a trailer…


#15

I type /tow nothing happens. Its in the server and the resource is started


#16

It also didn’t come with any server.lua if that makes a difference.


#17

Server.lua doesn’t matter.

Do you have a custom chat resource? If so it probably doesn’t support registercommand. Try updating your chat resource to the latest official fxserver chat resource.


#18

I have no clue what the original issue was, but it is working now, I just pulled the resource and put it back in


#19

Working great on my end! Is there any chance to find the .psd template for the flatbed 3?


#20

pounder_sign_1.zip (2.0 MB)
Not sure if it works, but this is the only template I could find. (sadly, no .psd, only a .png).