[Release] Head bag script [ESX] Version: 1.0.1


#21

Great release +1

Keep up the good work!


#22

I like your Menu who you have in screen can you send me link for it ? or


#23

I have a question. How to Open This HeadBag menu?


#24

Download newest version from today, add item headbag to your database and run script


#25

Ok insert the Headbag in items…

INSERT INTO items (name, label) VALUES
(‘headbag’,‘Headbag’)
;

…and how to use? Command, open menu?


#26

Cool release you got here.


#27

Open inventory > Headbag > Use and you will have menu.


#28

image

translate it to sack, push it…

Item:
image
there is no use…what I forgot, please?


#29

Try to add this item this way >
INSERT INTO items (name, label, limit) VALUES
(‘headbag’, ‘Sack’, 1),
;


#30

i will try it, will give feedback soon, thx


#31

Last update broke the script.

Headbag do not dissaper when put off.


#32

Wat? Can you give me more info?
Create GitHub issue and write in this exactly what are you doing and what is an error.
Ofc include console log.


#33

On my server, it won’t load server.lua.

I have tried to compile it and i got this error:

Error(s), warning(s):
lua5.3: source_file.lua:4: attempt to call a nil value (global ‘TriggerEvent’)
stack traceback:
source_file.lua:4: in main chunk
[C]: in ?


#34

Do you used TriggerServerEvent in server.lua? :joy:


#35

I haven’t touch anything.

EDIT: It’s TriggerEvent


#36

So script work :wink: Make sure you started this under es_extended and Clear cache…


#37

It’s still not working…

Script is correct installed, DB Item is correct, use it as item got this error:

InvokeNative: execution failed: Argument at index 1 was null.
Error running call reference function for resource esx_headbag: citizen:/scripting/lua/scheduler.lua:379: Execution of native 000000002f7a49e6 in script host failed.
stack traceback:
[C]: in upvalue ‘_in’
citizen:/scripting/lua/natives_server.lua:394: in function ‘TriggerClientEventInternal’
(…tail calls…)
server.lua:25: in upvalue ‘ref’
citizen:/scripting/lua/scheduler.lua:365: in function citizen:/scripting/lua/scheduler.lua:364
[C]: in function ‘xpcall’
citizen:/scripting/lua/scheduler.lua:364: in function citizen:/scripting/lua/scheduler.lua:363
stack traceback:
[C]: in function ‘error’
citizen:/scripting/lua/scheduler.lua:379: in function citizen:/scripting/lua/scheduler.lua:348
Error running system event handling function for resource es_extended: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: citizen:/scripting/lua/MessagePack.lua:830: missing bytes
stack traceback:
[C]: in function ‘error’
citizen:/scripting/lua/MessagePack.lua:830: in method ‘underflow’
citizen:/scripting/lua/MessagePack.lua:465: in field ‘any’
citizen:/scripting/lua/MessagePack.lua:860: in field ‘unpack’
citizen:/scripting/lua/scheduler.lua:602: in field ‘?’
server/functions.lua:168: in field ‘UseItem’
server/main.lua:466: in upvalue ‘handler’
citizen:/scripting/lua/scheduler.lua:195: in function citizen:/scripting/lua/scheduler.lua:194
stack traceback:
[C]: in function ‘error’
citizen:/scripting/lua/scheduler.lua:41: in field ‘CreateThreadNow’
citizen:/scripting/lua/scheduler.lua:194: in function citizen:/scripting/lua/scheduler.lua:158


#38

Maybe I’m blind…is this not the same?


#39

You see the difference? “Mesxage” instead of “Message” is the wrong part. It should be “Message”


#40

It works thx for helping, will use it and send a thumb!