[Release] Handcuff and Handsup scripts


#122

UPDATE

I have added cuffing by a keypress (X) it can be changed…

TBA

Config
Ped restriction
Player identifier restriction

#123

How to restrict to PEDS cuff?


#124

Could you make a version without Stringsplit? I keep getting Errors in chat.


#125

I dont know what script you are talking about this script hasnt used stringsplit in a while now :wink:


#126

https://gyazo.com/a22cbcc05074af7d1aaa0e98b394691e


#127

Have you not downloaded it again… why are you using such an old version of it.


#128

Could you make a version without the X to cuff?
This would be awesome.
I have some people accidently hit it when rping.


#129

Or they cuff other officers.


#130

I am not gonna make multiple versions for one person. If you want it edited then edit it to your liking. Thats not my responsibility to do that.


#131

I would if i could. Is there just a line of code i could remove?


#132

No and you can you just choose not to learn how to.


#133

Im, sorry. I actually balance my life with owning a server and having a job and a life. Usually developers help people with there code instead of making them change things with the script. People do want X key gone.


#134

Then change the X key. You don’t think I have a life? You don’t think I have a job? Just because I wrote this code doesn’t make me your servant. If you want what you want then YOU DO IT. Don’t come at me sideways because you didn’t get your damn way.

Here is the line to change the key just for you.

I am sure you would have figured that out if you would have actually tried instead of coming at me sideways because you think your life is much harder than mine.

EDIT

If you run a community and have no knowledge on even to change a key in the code god help you.


#135

How can you run a server without knowing how to change a key? :joy:


#136

Ok. So once i changed this, and even when i used the public. it doesnt cuff anyone X or the command. It just says returns true.


#137

I know how to change it. I just want it removed in general, but anyways i am currently issues with other things.


#138

still, that is no way to talk to a devloper that uses his spare time to help people that wont do it themself


#139

Its no way to talk to someone in need of help. When ever people need help with the resources i developed long ago. I dont even of have time sometimes but i still help. I may have been a little over, But i did try to remove the line of code just to have it not work.


#140

You can’t do that man I already told you that. You will need to write the code again to make it not work on a keypress at all. And dont even give me that crap about “no way to talk to someone in need of help” You were not asking for general help I don’t edit my code to make it work for your standards and as I told you “I don’t make multiple versions for one person”… If it doesn’t meet your “standards” then make it if you aren’t going to make it don’t treat me like I am a person in a cage that has nothing better to do then to help you with something I am not even obligated too just because apparently I don’t have a life and you do like give me a break.

Also keep in mind I don’t have to release shit. I can keep everything to myself if I want.


#141

Listen here. Im sorry for going over. I have just been agrivated by these cuff scripts ive tried multiple scripts. Cannot find one that worked correctly. I am not worried about the X key. I am wondering about “returns true” now. I am not that good with script. I have no idea how to fix this. No idea why i am getting this error when typing [/cuff (ID)] yet nothing comes up when pressing X/