[Release] Handcuff and Handsup scripts


#61

You most likely have another script interferring. Script is working fine for me.


#62

i just redownloaded deleted cache and rebooted and it fixed it


#63

Wait, does this add the handcuff prop to the player that gets handcuffed?


#64

Was working on it. But I don’t think the model I found is the correct one. Still searching for the model.


#65

I know it is a prop, I’ve never tried with non MP characters though. There is a pair that can be used with MP peds though. Maybe there’s a way to make them work with the normal peds,


#66

Just trying to find the model name.


#67

Is there a way to fix that when I cuff somebody and they either run or get into a vehicle they become uncuffed to stop happpening?


#68

I have never been uncuffed getting inside of a vehicle. Even the driver seat. I would need to recreate the issue to fix it.


#69

The character wouldn’t be in the emote/ animation of being cuffed in the car they would be normal and the same (without cuffs on) when they come out of the car or when they start to run the cuff animation/ emote comes off but they still register as them on.


#70

Hm. That’s weird. I may have a fix for that. Just gotta get around to fixing it.


#71

alright cool thanks :slight_smile:


#72

UPDATE
I made a possible fix to the players randomly getting uncuffed. Keep me updated!
Also fixed when players are cuffed or hands are up they can go forward and backwards in cars but they wont be able to turn left or right.


#73

Also is it possible to fix the animation breaking after ragdolling?


#74

It should be fixed though.


#75

when one ragdolls it breaks out of the animation. but your still restricted from hitting people etc.


#76

You downloaded the new version I put out yesterday?


#77

yes. It has all the new changes. but when I ragdoll form being hit by a car or form NumPad 1 (Lambda) it breaks out of the animation but is still cuffed…


#78

That is pretty weird. I thought I fixed that issue. I guess I will have to relook.


#79

Hi - this doesn’t seem to work. I get the “cuff command entered” but nothing happens to ped. Same for /hu command. I downloaded latest version from Nov of 2017.


#80

@Dixxycup You need to do /cuff id and if your /hu does not work then you did something wrong. Ive just downloaded this and works like a charm. Thanks @xander1998