[Release][FX]FiveMCalmAI


#21

okay did you extract the script dll and __resource.lua to a folder like for example “fivemcalmai”? so it is actually a resource? and also make sure you have the latest updated fxserver release.
@Floh please read the above. as it works fine for other people who are using the latest fxserver release.


#22

This script never worked on our server, the other one works fine… Not sure if its a vmenu compatibility issue or what…


#23

don’t know I use vMenu on my dev server too and I had no trouble with it.


#24

ya for some reason this script wont do much of anything AI still feel gang members still attack u like crazy everyone trys to gank u. i switch from the other version of this someone made to ur’s because it looked promising but its not doing anything


#25

are you sure you have the latest version of fxserver? because I have the latest one and the c# runtime on it makes it run fine? though it might be because I used newer features of the fivem c#/mono runtime that are only available in latest versions of fxserver.
now if you are asking about you don’t want to use the latest fxserver because of mumble there is a way to fix that see here: How to remove mumble completely [Guide]
when you make sure it is running as a client side script using the name “fivemcalmai.net.dll” or whatever it is called it loads it into the .net/c#/mono runtime instead of lua runtime which makes it work. without it running in the .net/c# runtime it won’t work because it isn’t lua based.

try just updating your fxserver to latest version and see if it fixes it.


#26

running the latest version of FX server for linux on our box right now and we have mumble disabled. it still seems to not do anything all the ai freak on gunshots gang members engage right away and civs dont back down

Edit. ran the latest version of windows FX server on my personal PC and still not working


#27

try Windows 2012R2 Standard, I currently having it running fine on my FXServer running on a windows 2012R2 dedicated server.


#28

Newest build, does nothing, is there a trick to installing it?


#29

I will test it again on my development fivem server and let you know, because I don’t know why it isn’t loading for you all anymore, maybe the c# runtime I am using needs to be updated in the script? I mean I wouldn’t know what to tell you until I can reproduce the problem myself during my testing to see what might be causing the issues with it not loading. I will get back to you on that once I complete my testing and upload a fixed build once I can validate it works again after my testing.