[Release] Freeroam 2 by Kanersps

#113

I solved it, it seems the MySQL connector file was blocked by the OS, even on Ubuntu.
Now it works on all of the operating systems I tried,
I’ts a stupid mistake I made by not checking the security settings. Stupid me :smile:.
So yes, I’m dumb as ****.

0 Likes

#114

CitizenFX.log (540.3 KB)

Any one can please help me with this? Already fix resources/freeroam/lib/MySql.Data.dll’)` bla bla, but stil stuck in this black screen, i have create my DB in mysql workbench and works fine, the register system is working. My game is update steam version, fivem-map-skater works fine but this game mod no. Please, help me.

2 Likes

#115

Add - fivem-map-skater in citmp-server.yml under AutoStartResources. Because you just dont have any map and gametype running.

2 Likes

#116

Yes you’re right @Arturs!

I just tried it and it works!

Thanks for all your support guys!

Svensson

0 Likes

#117

I seem to be getting this error when I do /register Console I dont know what file I would edit or where to even begin.

0 Likes

#118

What did you do to unblock the MySQL connector file?

0 Likes

#119

Just right click the MySql.Data.dll file that can be found under resources\freeroam\lib , and unblock it, That’s all.

Also make sure your firewall isn’t blocking the server or your MySQL server.

0 Likes

#120

Hello ,

I want say allready you work is realy good… Now I whant add some command in your Freeroam but any test is over! Can you tell me vhere I can put new command?

Thanks
Cedric

0 Likes

#121

Thank you for this nice script ! But i have one problem ! Im typing /register and my password and nothing is happening ! Can someone help me !

0 Likes

#122

Thanks! I would have totally missed that. Did you compile a MySQL server into you game server directory, run it as a installed service, or did you install something like WAMP, LAMP, or XAMPP?

0 Likes

#123

I used a wamp stack, the latest version of Ampps.
I had it already intalled, because I do some experimenting in javascript and php from time to time.
But you can use any wamp stack for this purpose, as long as the MySql version supports utf8mb4.
If you intall it in the server directory, you can make it automatically start from run.bat when you start the fivereborn server.

@echo off
start wamp/usbwebserver.exe %*
start CitizenMP.Server.exe %*

There is nothing to it, just add a line like the code above in your run.bat depending on which version you use, and the wamp stack will start first, before the five reborn server starts.
In this example i used Usbwebserver, but that doesn’t matter. You can use any wamp stack as I mentioned before, as long as the MySql version shipped with it supports utf8mb4.

0 Likes

#124

I really appreciate your insight Rich, I really appreciate it. I think my hang up is something with Windows 10. I put a DWord into the registry to stop the need to having to unblock certain files from other computers. I re-downloaded everything, to be sure, set my WAMP back up, created the database, edited the register.lua, added freeform to the load order, disabled my firewall (Just to be sure), and nothing. It’s making me want to pull my hair out, because I have mucked with server admin stuff for a long time and I know it has to be something simple.




0 Likes

#125

Hey,
I have a question about this script,
I installed the freeroam in my resources blabla and im running a database with heidisql like it stays in the description, but when i join the server i see the black thing with quick rules and when i type a command it does nothing and my console getting spammed. Hope u can help me.
Thanks.

0 Likes

#126

ye i have the same problem

0 Likes

#127

Did you use wamp or a mysql server installer?
Its possible that your register.lua file is blocked by the OS as well. What I did was install xampp and just ran the sql server from that and it ran smoothly from there

0 Likes

#128

i use wamp… this is just to get 20 letters

0 Likes

#129

But, how can i unblock it, is doesnt say unblock or something and don’t see if my avg is blocking it. can u explain how to unblock before ill install xampp, or do you have skype and teamvieuwer so u can help me from there, its not that i use sql shit much

0 Likes

#130

This is not supported anymore at all, use this: [Release] EssentialMode base

Locked

0 Likes

closed #131
0 Likes

[Release] EssentialMode base
unlisted #132
0 Likes