[Release] [ESX] [Mechanic Job]


#22

#23

So quick, THANKS for taking the time to help a noob


#24

I can see there there’s a craft menu, but it requires you to be experienced. No matter what grade I give the player, he still needs to be experienced (even with the experienced and boss grade). How exactly does this work?

And I’d like anyone to be a mechanic, therefore I have disabled society and player management because I don’t want any grades and all that. But I still got “Deposit Stock” and “Withdraw Stock” in the menu (no matter what rank), and also whenever I tow NPC vehicles to the garage - the money goes to the “company”, not myself?


#25

Did you fix the craft menu? having the same issue…


#26

You see? Is that all those Icons on map for this job? Mechanic Icons on map :slight_smile:

Cause there are LOTS of them, and i was thinking maybe to shrink it down to a few.


#27

Im having trouble with this, i got the job but when i go to customs location i cant see the spawn locations circles nowhere, ive gone to right place because i checked the cord. but they wont appear.


#28

Were you able to fix the issue where the mechanic company is paid instead of players? I’m having the same problem. Society is disabled in mechanic config.


#29

im having the same problem as Norl. Can anyone help?


#30

Hi dude, i just solved it. GO to you billing resource and change the target type to player instead of society. Hope that helps


#32

Do you mean the billing resources in esx_billing (billing/server/main.lua) ? That’s crashing the server so I wanted to make sure that’s the right place.


#33

Is there AI missions too? You get a waypoint, there u have to tow the car and bring it back to the garage and drop it off there. If not, is there a way to add it?


#34

Can someone help me why you can not park out the vehicles at the mechanic?

Error running call reference function for resource esx_society: citizen:/scripting/lua/scheduler.lua:351: server/main.lua:363: attempt to index a nil value (local 'store')
stack traceback:
        server/main.lua:363: in upvalue 'ref'
        citizen:/scripting/lua/scheduler.lua:337: in function <citizen:/scripting/lua/scheduler.lua:336>
        [C]: in function 'xpcall'
        citizen:/scripting/lua/scheduler.lua:336: in function <citizen:/scripting/lua/scheduler.lua:335>
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/scheduler.lua:351: in function <citizen:/scripting/lua/scheduler.lua:322>
        [C]: in function 'coroutine.resume'
        citizen:/scripting/lua/scheduler.lua:34: in field 'CreateThreadNow'
        citizen:/scripting/lua/scheduler.lua:335: in function <citizen:/scripting/lua/scheduler.lua:322>
Error running system event handling function for resource esx_datastore: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: citizen:/scripting/lua/MessagePack.lua:830: missing bytes
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/MessagePack.lua:830: in method 'underflow'
        citizen:/scripting/lua/MessagePack.lua:465: in field 'any'
        citizen:/scripting/lua/MessagePack.lua:860: in field 'unpack'
        citizen:/scripting/lua/scheduler.lua:563: in local 'cb'
        server/main.lua:106: in upvalue 'handler'
        citizen:/scripting/lua/scheduler.lua:175: in function <citizen:/scripting/lua/scheduler.lua:174>
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/scheduler.lua:41: in field 'CreateThreadNow'
        citizen:/scripting/lua/scheduler.lua:174: in function <citizen:/scripting/lua/scheduler.lua:138>
hitch warning: frame time of 177 milliseconds

#35

How to I obtain items to fix vehicles? When I walk into the yellow ring in the la customs it says im not experienced enough to craft.

Edit: Solved the problem by enabling Config.EnablePlayerManagement.


#36

Hi,
Everytime I walk into the marker as a Mechanic it says I’m not experienced enough to craft anything.

I change:-
“Config.EnablePlayerManagement = true
Config.EnableSocietyOwnedVehicles = true”

These both to true. I start up the server redownload the config from the server and its been reset back to false every time.

Any ideas?

Edit: Solved it by removing esx_mecano out the ESX folder and placing it inside the Resources without being inside ESX.


#37

are u using zaphosting? they just released a new feature, my esx_policejob got reverted.


#38

Hi, Yes I am. I just managed to fix the problem. Just about to edit my previous comment if you want to find out how I fixed it


#39

Can you pm me and tell me how you fixed it?


#40

Hi, I have a small problem on my server.
Somehow all the upgrades on all cars costs 500, doesent mather if its stage 1 or stage 5.
Everything cots 500. Anyway to change this back to the usual “depends on the price of the car” thing?

And i cant put money in the mecano account, even if i manualy do it, it does have “playermanagement: True” option


#41

Silly question, but where to get the truck without spawning it?


#42

with a vehicle spawn menu. Or car dealer can sell it if you have it set up that way