[RELEASE][ESX] KASHacters Multi Character

esx
characters

#374
[EssentialMode] Current version: 6.1.0
[EssentialMode] Updater version: 6.1.0

Access denied for command sets.
Access denied for command sets.
[EssentialMode] Everything is nice and updated!

Connecting: ENEKO1225
Sending heartbeat to live-internal.fivem.net:30110
nil     ~=      1
Error running call reference function for resource esx_skin: citizen:/scripting/
lua/scheduler.lua:403: server/main.lua:39: attempt to index a nil value (local '
xPlayer')
stack traceback:
        server/main.lua:39: in upvalue 'ref'
        citizen:/scripting/lua/scheduler.lua:389: in function <citizen:/scriptin
g/lua/scheduler.lua:388>
        [C]: in function 'xpcall'
        citizen:/scripting/lua/scheduler.lua:388: in function <citizen:/scriptin
g/lua/scheduler.lua:387>
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/scheduler.lua:403: in function <citizen:/scriptin
g/lua/scheduler.lua:372>
Error running system event handling function for resource es_extended: citizen:/
scripting/lua/scheduler.lua:41: Failed to execute thread: citizen:/scripting/lua
/MessagePack.lua:830: missing bytes
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/MessagePack.lua:830: in method 'underflow'
        citizen:/scripting/lua/MessagePack.lua:465: in field 'any'
        citizen:/scripting/lua/MessagePack.lua:860: in field 'unpack'
        citizen:/scripting/lua/scheduler.lua:626: in field '?'
        server/functions.lua:33: in field 'TriggerServerCallback'
        server/common.lua:63: in upvalue 'handler'
        citizen:/scripting/lua/scheduler.lua:219: in function <citizen:/scriptin
g/lua/scheduler.lua:218>
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/scheduler.lua:41: in field 'CreateThreadNow'
        citizen:/scripting/lua/scheduler.lua:218: in function <citizen:/scriptin
g/lua/scheduler.lua:182>
Access denied for command add_principal.
Recherche ... : 0761743164
Numero Choisi  : 0761743164
Sending heartbeat to live-internal.fivem.net:30110


#375

did you add the command switching ? and stuff that goes with it?


#376

when i put /swith and select my player , its puts a black windows . And my character isn´t save it https://cdn.discordapp.com/attachments/549260614913228810/555435977997549587/unknown.png


#377

Then remove that feature. Just use normal kashacter with no edit. Edit just what it really needs.
So start again install kashacter normaly dont make edit like hospital and such just do your table and the edit of the essential with the error fix. Thats it. Then test.


#378

https://gyazo.com/3db6229e89c0aceb18cfc422dbddd745


#379

youll have to fix it in the css and js. I do not use kashacter anymore. So if your using it, youll have to fix yourself.


#380

getting the same error as the guy above may be the new fivem update


#381

What errors were you getting?


#382

Working ?


#383

How can I fix issue with reloading UI to switch character in game it shows play button before a character is selected. How can I fix this?


#384

It was the duplication errors mostly.


#385

Did anyone fixed the skin problem, everytime people join some don’t have there character skin and they run around with normal peds


#386

It’s up in the comments there is a code fix


#387

I was still getting errors… i did this on my server… and now its working like a charm.

Citizen.CreateThread(function()
while true do
Citizen.Wait(0)
if NetworkIsSessionStarted() then
TriggerServerEvent(“kashactersS:SetupCharacters”)
TriggerEvent(“kashactersC:SetupCharacters”)
return – break the loop
end
end
end)

Not sure why taking that out fixed it for me… but it was causing major issues but working great now.


#388

is this the skin fix ? and where do i place this code


#389

I updated my core system and updated skin and it works fine now… but this was a comment from above… where when you login or switch it would just hold at a black screen.


#390

you not duplicating once you log out


#391

any idea how to fix the cursor disappearing some people can see it some carnt it fixed when you do restart in rcon but the some carnt see it after that


#392

i still got the error

Started resource esx_kashacters
cfx> Error resuming coroutine: citizen:/scripting/lua/json.lua:397: bad argument
 #1 to 'strfind' (string expected, got nil)
stack traceback:
        [C]: in function 'string.find'
        citizen:/scripting/lua/json.lua:397: in upvalue 'scanwhite'
        citizen:/scripting/lua/json.lua:553: in function <citizen:/scripting/lua
/json.lua:551>
        (...tail calls...)
        @esx_kashacters/server/main.lua:27: in upvalue 'handler'
        citizen:/scripting/lua/scheduler.lua:219: in function <citizen:/scriptin
g/lua/scheduler.lua:218>

i have everything updated anyone can help me?


#393

Thank you for your nice character menu.

Is it normal that every character has the same inventory?

I am using ESX.