[RELEASE][ESX] KASHacters Multi Character

esx
characters

#354

Ignore it it’s normal


#355

same here, still working on it


#356

Voice issues are related to a fivem update. They tried to put mumble back on ever instance of fivem not just the onesync. if you remove it out of everything you should be good. One of the servers im on talk about. At least from everything ive read…


#357

For some players script is not loading and they spawn immediately and i have multiple ESX lua errors in console. They are just regular PEDs


#358

did u fix the j._atm error?


#359
Error running system event handling function for resource hakan-atm: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: server.lua:128: attempt to index a nil value
stack traceback:
        server.lua:128: in upvalue 'handler'
        citizen:/scripting/lua/scheduler.lua:219: in function <citizen:/scripting/lua/scheduler.lua:218>
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/scheduler.lua:41: in field 'CreateThreadNow'
        citizen:/scripting/lua/scheduler.lua:218: in function <citizen:/scripting/lua/scheduler.lua:182>

I have problem on jsfour-atm


#360

and one more problem in first join :

Error: (node:45964) UnhandledPromiseRejectionWarning: TypeError: Cannot convert undefined or null to object
    at Function.values (<anonymous>)
    at execute.then (mysql-async.js:5002:48)
Error: (node:45964) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
Error: (node:45964) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

#361
Error resuming coroutine: citizen:/scripting/lua/json.lua:397: bad argument #1 to 'strfind' (string expected, got nil)
stack traceback:
[C]: in function 'string.find'
citizen:/scripting/lua/json.lua:397: in upvalue 'scanwhite'
citizen:/scripting/lua/json.lua:553: in function citizen:/scripting/lua/json.lua:551
(...tail calls...)
server/main.lua:37: in upvalue 'handler'
citizen:/scripting/lua/scheduler.lua:219: in function citizen:/scripting/lua/scheduler.lua:218


When i try to play as a character


#362

Hey guys loving the plugin, using it and modifying some specific things to incorporate. Having a couple issues with ambulance - no matter what i do (change/alter/tons of code edits from all sorts of people) something is going wrong. Depending on which way you put the code in, it causes a couple different problems
1 users auto restart even if they die, they seem to restart instantly without a timer/cost for revive and their items do get taken away.
2 when someome dies you’re able to revive them, they come back, the timer does not disappear beneath them. Still will say G for signal and the timer for respawn. The player IS alive though, just unable to move.
3 the player dies and is unable to revive even on admin, ems cant revive - only way to fix currently is admin revives them, they pm admin, admin has to restart ambulance manually.

Definitely love this plugin but any help or guidance you’ve got id be extrememly gratedul for. Thanks! DrRogue#3765


#363

Since a lot of you are messaging me for my modified version of the UI. I decided to release it. I was not done with it and that is the reason i did not share my version yet. But since i get a lot of people that wants it. Here it is. I had plan on adding more too it. But i do not use this resource anymore. It cause too many error. Fixable yeah if you put the time into debugging it but i have other scripts to tweak and clean up code.

Screenshot

Download
html.rar (6.1 KB)

Installation
Delete html folder from your kashacters resource then drop mine.
Enjoy!

No support will be given. If you use this you will have to edit it to your liking.


#364

Hello, I followed your guide to install the plugin, everything works correctly but the skincharger does not load my character I have esx_identity


#365

You could try to load them in this order

start esx_kashacters
start esx_identity
start skinchanger
start esx_skin

Maybe this will fix it. I’m not sure.


#366

set onesync_enabled 0.

start mapmanager
start chat
start spawnmanager
start sessionmanager
start fivem
start hardcap
start rconlog
start playernames
start async
start mysql-async
start essentialmode
start esplugin_mysql

#ESX BASE
start es_extended
start esx_menu_default
start esx_menu_list
start esx_menu_dialog
start esx_personmeny

start esx_datastore
start esx_addonaccount
start esx_addoninventory
start esx_billing
start esx_status

start esx_kashacters
start esx_identity
start skinchanger
start esx_skin

start cron 
start esx_society
start esx_license
start esx_basicneeds
start esx_optionalneeds

start esx_vehicleshop
start esx_property
start esx_accessories
start esx_doorlock
start esx_shops
start esx-kr-bag-inventory
start esx_teleport
start esx_hacking
start esx_jobs
start esx_joblisting
start esx_voice
start esx_aircraftshop
start esx_boatshop
start esx_jb_eden_garage
start esx_holdupbank
start esx_borrmaskin
start esx_ktackle
start esx_legacyfuel

##Trabajos
start esx_policejob
start esx_ambulancejob
start esx_hunting
start esx_lscustom
start esx_vigneronjob
start esx_mechanicjob
start esx_fib
start esx_ammupzr

start sky_armas
start sky_lspd
start sky_lspdcoches
start CarCommand
start sky_heli
start lux_vehcontrol
start es_admin2
start allcity_medical
start bob74_ipl
start ft_libs
start instance
start cron
start discord
start sky_pantalla
start sky_motolspd
start sky_animarmas
start sky_anim
start sky_pausa
start sky_marcadeagua
start sky_whitelist
start sky_armavisible
start sky_antidisturbios
start sky_manosarriba
start sky_rendirse
start disabledispatch
start coffe_policestation
start c_policestation_needs
start sky_lambo
start eden_accesories
start sandy
start NativeUI
start gcphone
start vdk_call
start eup-stream
start eup-ui
stary sky_phone
start sky_personaje
start jsfour-idcard
start sky_disparar
start sky_escudo
start sky_rastreo
start pNotify
start sky_ame

This is my start order


#367

It should work so look console for errors. You probably have an error.
and you have this error not related to skin but stary sky_phone should be start sky_phone


#368
Error running call reference function for resource esx_skin: citizen:/scripting/
lua/scheduler.lua:403: server/main.lua:39: attempt to index a nil value (local '
xPlayer')
stack traceback:
        server/main.lua:39: in upvalue 'ref'
        citizen:/scripting/lua/scheduler.lua:389: in function <citizen:/scriptin
g/lua/scheduler.lua:388>
        [C]: in function 'xpcall'
        citizen:/scripting/lua/scheduler.lua:388: in function <citizen:/scriptin
g/lua/scheduler.lua:387>
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/scheduler.lua:403: in function <citizen:/scriptin
g/lua/scheduler.lua:372>
Error running system event handling function for resource es_extended: citizen:/
scripting/lua/scheduler.lua:41: Failed to execute thread: citizen:/scripting/lua
/MessagePack.lua:830: missing bytes
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/MessagePack.lua:830: in method 'underflow'
        citizen:/scripting/lua/MessagePack.lua:465: in field 'any'
        citizen:/scripting/lua/MessagePack.lua:860: in field 'unpack'
        citizen:/scripting/lua/scheduler.lua:626: in field '?'
        server/functions.lua:33: in field 'TriggerServerCallback'
        server/common.lua:63: in upvalue 'handler'
        citizen:/scripting/lua/scheduler.lua:219: in function <citizen:/scriptin
g/lua/scheduler.lua:218>
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/scheduler.lua:41: in field 'CreateThreadNow'
        citizen:/scripting/lua/scheduler.lua:218: in function <citizen:/scriptin
g/lua/scheduler.lua:182>
Sending heartbeat to live-internal.fivem.net:30110


#369

Try using latest version of esx_skin and skinchanger.


#370

Im using the last version of both plugins


#371

Then i don’t know what to tell ya.
it’s something to to with attempt to index a nil value (local ’
xPlayer’) So somewhere something is missing. So it wants to look for xplayer but its not define. nil=null
So you’ll have to find it yourself or start over.


#372

Okay, I’ve reinstalled it and it seems to work but there’s still the problem of the skin


#373

same error as above?