[Release][ESX] [Jobs]


#23


#24

Whats the bdd? and where can i find it.


#25

Database “Wampserver”


#26

I can not get it on the map you can help


#27

I’m also unable to get the blips on the map, and even after changing the language settings it’s still in french

after I’ve done everything I get the following issues - does anyone know how to resolve these


170204] citizen:/scripting/lua/scheduler.lua:163: in function citizen:/scripting/lua/scheduler.lua:162
[ 170219] stack traceback:
[ 170219] [C]: in function ‘error’
[ 170219] citizen:/scripting/lua/scheduler.lua:41: in field ‘CreateThreadNow’
[ 170235] citizen:/scripting/lua/scheduler.lua:162: in function citizen:/scripting/lua/scheduler.lua:131
[ 170391] Error running system event handling function for resource esx_jobs: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: server/esx_jobs_sv.lua:32: attempt to index a nil value (global ‘ESX’)
[ 170407] stack traceback:
[ 170407] server/esx_jobs_sv.lua:32: in upvalue ‘handler’
[ 170407] citizen:/scripting/lua/scheduler.lua:163: in function citizen:/scripting/lua/scheduler.lua:162
[ 170422] stack traceback:
[ 170422] [C]: in function ‘error’
[ 170422] citizen:/scripting/lua/scheduler.lua:41: in field ‘CreateThreadNow’
[ 170438] citizen:/scripting/lua/scheduler.lua:162: in function citizen:/scripting/lua/scheduler.lua:131
[ 300891] Sending heartbeat to live-internal.fivem.net:30110
[ 461860] Error running system event handling function for resource esx_jobs: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: server/esx_jobs_sv.lua:15: attempt to index a nil value (global ‘ESX’)
[ 461875] stack traceback:
[ 461875] server/esx_jobs_sv.lua:15: in upvalue ‘handler’
[ 461891] citizen:/scripting/lua/scheduler.lua:163: in function citizen:/scripting/lua/scheduler.lua:162
[ 461891] stack traceback:
[ 461891] [C]: in function ‘error’
[ 461907] citizen:/scripting/lua/scheduler.lua:41: in field ‘CreateThreadNow’
[ 461907] citizen:/scripting/lua/scheduler.lua:162: in function citizen:/scripting/lua/scheduler.lua:131



#28

I decided to try making a new server and redo the db from scratch but still no luck in seeing anything on the map here is what I’m starting from server.cfg incase I have something in the wrong order.

start mapmanager
start chat
start spawnmanager
start scoreboard
start sessionmanager
start fivem
start hardcap
start rconlog
start baseevents

start mysql-async
start essentialmode
start esplugin_mysql
start es_admin2
start es_extended

start esx_menu_default
start esx_menu_list
start esx_menu_dialog

start skinchanger
start esx_skin
start esx_lscustom
start esx_addonaccount
start esx_jobs
start esx_ambulancejob


#29

Got it working now I was missing joblisting


#31

Hello DrDJ what is the JobListing ? It resolved your problem ?


#32

It’s an esx plugin on their github here’s a link https://github.com/ESX-Org/esx_joblisting


#33

Hello, when I enter job center area, and I press “E”, nothing happens


#34

I fixed the problem, but now when I go to vehicle spawn point, there is nothing there


#35

never mind, It appears you need to wear workers close to see other checkpoints lol


#36

Hi I was wondering what version of essentials you are using?


#37

All good, I finally got it to work, all I needed to do is open my eyes…Those bedroom eyes I must admit I’m not surprised…lol


#38

it keeps saying #1044 - Access denied for user ‘db9962’@’%’ to database ‘essentialmode’ how do i fix this


#39

this looks like you set wrong credentials. Thats why your database say “Access denied”.


#40

I am having issues with the jobs, i installed job listing but the menu wont pop up when i press E, anybody know how to fix it?


#41

You have to install the Joblisting script from the ESX-ORG github


#42

Hi guys i have allso the problem where i can press e and nothing happens someone said i have fixed this but did not say how … it would be appreciated if a explanation was given even a simple one.cheers in advance.


#43

I installed the joblisting script from the ESX-ORG: github https://github.com/ESX-Org/esx_joblisting then went to the indilo53’s original esx file: https://github.com/indilo53/fivem-esx_joblisting and installed the SQL that was there into my database. Worked for me. Hopefully it works for you @kobraking