[Release] ESX-ALphone (call system)


#281

Does anyone know why when i bring up the phone, it gets stuck in my hand and i have to press F2 to make it work?


#282

I fixed the hand problem. I think it had to be Detach entity rather than Delete Object. Should be a faster close for the phone as well


#283

Hi i have one big problem, im testing this phone and cant work… console making error like this any idea how to fix this? Yes i see problem in database and i dont have idea how with this…Thanx :slight_smile:


#284

where can i change the key to open the phone???


#285

ESX_phone3 -> Client -> main.lua -> if IsDisabledControlJustReleased(0, Keys[‘F1’]) then


#286

Lovely how i can’t create a simple topic searching for help beacuse I ‘‘have’’ to ask here. 70% of the time you do not get an answer, but i’ll try once again. Is there a way to create a code so when you do not have a phone, people cant text or call you? I’ve tried some, but they do not work.


#287

Getting the same error. Any solution?


#288

Hi. I have problem. My phone dont show the phone number… How fix it ?

image


#289

You might not be connected to the database. PM me I’ll try to help you out.


#290

I cant find the map there i change the apps pictures! like police you know


#291

beacuse there isnt a folder for it. look in the client for policejob and you will find it there. If you are using esx_policejob that is.


#292

I already have change it, but i didn’t work for me


#293

Have anyone solved how to add “remove contact” feature?


#294

how to add jobs into the phone ?


#295

So in whatever job resource that you want to have in the phone. Add this to the server.lua

TriggerEvent('esx_phone:registerNumber', 'JOBNAMEHERE', _U('alert_JOB'), true, true)

Note: you are gonna have to add alert_JOB to your locale file or change _U(‘alert_JOB’) to “alert_JOB”

Then in the index.html of the esx_phone3
Add in this after

<div class="menu-icon menu-icon-JOBNAME" data-app="contact-action-message" data-args="{&quot;name&quot;: &quot;JOBNAME&quot;, &quot;number&quot;: &quot;JOBNAME&quot;}">
						<div class="menu-icon-inner">
							<i class="fa fa-heartbeat fa-fw"></i>
						</div>
						<div class="menu-icon-label">JOB TITLE</div>
					</div>

The order you have your data is the order it will show on the phone so keep that in mind.

If you want to change the Icon you can change it by going here https://fontawesome.com/v4.7.0/icons/ Searching for an icon and using the title like fa fa-heartbeat fa-fw that you see above in my html example.


#296

Hey, I know you said you had this working a long time ago. You have no errors? I keep getting this error:
Error running system event handling function for resource esx_phone3: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: server/main.lua:313: attempt to index a nil value (field ‘?’)
stack traceback:
server/main.lua:313: in upvalue ‘handler’
citizen:/scripting/lua/scheduler.lua:175: in function citizen:/scripting/lua/scheduler.lua:174
stack traceback:
[C]: in function ‘error’
citizen:/scripting/lua/scheduler.lua:41: in field ‘CreateThreadNow’
citizen:/scripting/lua/scheduler.lua:174: in function citizen:/scripting/lua/scheduler.lua:138


#297

Did you ever find a fix to that error?


#298

Same issue here. Did you find a fix?


#299

Sorry for my bad English :slight_smile:
Recently i update my server with gcphone and vdk_call
The calls doesn’t work before new phone. At esx_phone3 that didn’t work too.
In my server.cfh all things seems to be good, without esx_service.
And here is my question. Esx_service must be before or after phone?
And if before pls type me how to fix it. Thanks a lot :smiley:


#300

Esx_Service can be after the phone stuff. Make sure you carent calling gcphone or vdk_call during the same time you are testing phone3 not sure if it would fight with one another