[Release] ESX-ALphone (call system)


#211

How change form Button “1” to Button “F1”


#212

got the same problem it seems like it dont understand when its trying to send a nil value. i get the error when u disconnect from the server

AddEventHandler(‘esx_phone:removeSource’, function(number, source)
PhoneNumbers[number].sources[tostring(source)] = nil-- error Nil value
end)

dont really know right now gone test it see whats the problem.

same with all the jobs dont get the msg from you when u send it. and the GPS system seems to be a bit faulty

Edit,

manage to fix the Message to Jobs “Police” you have to change the names in index.html

-> "Police&quot to "police&quot

as u can see down below how to fix the msg and the GPS to the jobs so a officer or the job u add gets the msg.

< div class=“menu-icon menu-icon-police” data-app=“contact-action-message” data-args="{“name”: “police”, “number”: “police”}">


#213

it is in mani.lua row 478 if IsDisabledControlJustReleased(0, Keys[‘F1’]) then


#219

Hi guys,

Someone know how to remove contact and message ? And for me, the GPS with [u] doesn’t work, someone fix that ?

Thank you guys ^^


#222

The U doesnt work… because the jobs sometimes got it already in their script…
And contacts are saved in sql


#224

Hey Gus I have a Proben in my phone is apps i will delete the choffeur bank etc but who i can this delete?


#225

who i can translate the apps (police) (ambulance) etc??


#226

how to disable phone if player doesn’t have it in his inventory?


#227

how do I change the key? I can’t find it!


#228

you havent searched then, client.lua if iscontrol


#229

but there isn’t key for taking out phone


#230

When you take up the phone my character is doing the “phone call” animation.
When I put down the phone it’s stuck in my hand.
I need to click f2 then f1 to take up the phone
How do I solve it?


#231

Mod works, even calling, but spits out this error:

Error running system event handling function for resource esx_blackberry: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: server/main.lua:32: attempt to index a nil value (local 'blackberry')
stack traceback:
	server/main.lua:32: in upvalue 'handler'
	citizen:/scripting/lua/scheduler.lua:175: in function <citizen:/scripting/lua/scheduler.lua:174>
stack traceback:
	[C]: in function 'error'
	citizen:/scripting/lua/scheduler.lua:41: in field 'CreateThreadNow'
	citizen:/scripting/lua/scheduler.lua:174: in function <citizen:/scripting/lua/scheduler.lua:138>


#232

because you havent added blackberry to db


#233

But I made an entry in “items”.

Do I have on somewhere else too?

Another issue is I can’t send messages to the reporter job and unemployed ones. It’s named the same in the html as in the db. Any ideas?


#234

I have a problem with my phone, it is impossible to add a contact or call because it is still written with $ 0 and I have enough

InvokeNative: execution failed: Argument at index 1 was null.
Error running call reference function for resource esx_phone3: citizen:/scripting/lua/scheduler.lua:351: Execution of native 000000002f7a49e6 in script host failed.
stack traceback:
[C]: in upvalue ‘_in’
citizen:/scripting/lua/natives_server.lua:334: in function ‘TriggerClientEventInternal’
(…tail calls…)
server/main.lua:380: in upvalue ‘ref’
citizen:/scripting/lua/scheduler.lua:337: in function citizen:/scripting/lua/scheduler.lua:336
[C]: in function ‘xpcall’
citizen:/scripting/lua/scheduler.lua:336: in function citizen:/scripting/lua/scheduler.lua:335
stack traceback:
[C]: in function ‘error’
citizen:/scripting/lua/scheduler.lua:351: in function citizen:/scripting/lua/scheduler.lua:322
[ERROR] [MySQL] Check the error above, an error happens when executing the callback from the query : “SELECT phone_number FROM users WHERE phone_number = @number {@number=12358}”

please help
file - server.cfg

start esx_phone
start esx_phone3
start esx_blackberry

database

INSERT INTO items(Name, Label) VALUES
( ‘Blackberry’, ‘Black Berry’);
| id | name | label | limit | rare | can_remove |
| 54 | Brombeere | Black Berry | -1 | 0 | 1 |

The phone with these settings does not work anymore


#235

Hi guys,

Someone know how the Icon of the DeepWeb show even I’ve not Blackberry on my inventory ? It’s strange !

I got blackberry on my table item and I got esx_alphone + esx_blackberry start

Someone have a solution ? I’ve try lot of stuff…nothing work :frowning:

Thank guys, have a nice day !


#236

The phone was working fine for a long time, now when we call someone for voice chat, we can’t hear each other… anybody know why ?


#237

Dispatches don’t working, can me on help pls?


#238

Same here, if you figured it out i would appreciate some help.