[Release] EssentialMode base


#21

Did you change the code in login.lua?

MySQL:open("127.0.0.1", "gta5_gamemode_essential", "root", "1202")

You have to open login.lua and change these based upon your database (“IP”, “databasname”, “user”, “password”)
The database name and ip might be fine but “1202” needs to be the password connected to the root user


#22

Several of our Clients requested we support this Framework as a one click install, this has been added to our hosting platform


#29

Removed posts, look at what the topic says. No mysql questions asked to me or in this topic.


#30

Thanks for this good work Kane :slight_smile:

how can i spawn a car or give cash out of the sql table by command? can u give an example?


#32

For spawning:

/vehicle [vehiclename]

Haven’t tried giving out money yet though. Maybe someone else knows.


#33

Year the default is set as an Admin command ( /car [vehicle] ).
I am looking for a player command to spawn his own personal vehicle and not
every vehicle on the server like a admin can.
There is a vehicle sql table i wanna use. I know how to read the table but didnt know how to
use it for spawning or players give other players money.´…and so on
I love the script an realy what to add some stuff. Its very fun.

So how to trigger is the question :slight_smile:


#34

Had to like, this is the kind of comments I want.

Anyhow, for an example of giving money take a look at the admin resource, there’s an rcon command for it.


#35

hahaha, :slight_smile: thats exactly what i tryed out, but no way to get it working.
I try it again. Im on the right way^^


#36

How comes I cannot use any commands ingame? I’ve set myself to admin and nothing happens :confused:


#37

Dont forget to set -es_admin in the citmp-server.


#38

Hey, thanks for the response, I have that but it still doesn’t work… could you send me an example command to make sure I have the format correct in chat?


#39

there are a few command in the server/recources/[essentials]/es_admin/sv_admin.lua

In chat try /admin for this code in sv_admin.lua

TriggerEvent(‘es:addCommand’, ‘admin’, function(source, args, user)
TriggerClientEvent(‘chatMessage’, source, “SYSTEM”, {255, 0, 0}, “Your permission level is: ^2” … user[‘permission_level’])
end)

Output is: Your permission level is: 4

*edit no permission_level needed, sorry


#40

just gave it a try in-game, nothing happens when I tried /admin in chat


#41

when sql is running and working it have to work


#42

Console commands work, but not the ingame commands :S


#43

you shouldn’t have a modified chat resource.


#44

What do you mean by chat resource? I haven’t modified anything to do with the chat :slight_smile:


#45

I’m getting the same problem :S


#46

if you find a fix for this can you let me know (and vise versa) :slight_smile:


#47

Yeah I will do, been looking since I last responded… cant find a fix :confused:

EDIT - I fixed it, I mounted it in the config folder before “essentialmode” you must do it after, not before.