[Release] EssentialMode base


#2730

Do you have ESX server??


#2731

It still doesn’t work for me, I’ve installed it and the cash is still not showing up

edit: It does work but only when I add/remove cash from es_admin


#2732

Hey Ive been trying to make a esx server with essentialmode 6… I have the permissions set up in server.cfg to allow setgroup 1 superadmin but it just dosnt work. Remade server 3 times including the db… dont know what to do at this point. Please help.

add_ace resource.essentialmode command.add_principal allow

comes back access denied

:frowning:


#2733

Me myself have the problem with commands not existing. /setjob does not work for me, neither do /car. After the 6.0.X updates… I’ve fully read the documentation (installation part) but it does not work.
Any ideas?


#2734

EssentialMode Admin update

  • Few GUI fixes
  • New ban system!

For information about the new ban system go to the following documentation:
https://wiki2.kanersps.pw/display/FIV/ES_Admin#ES_Admin-Banning


#2735

this error i have on two of the three servers i am running any ideas ? I tried to narrow it down no luck

Error running system event handling function for resource essentialmode: citizen
:/scripting/lua/scheduler.lua:41: Failed to execute thread: citizen:/scripting/l
ua/json.lua:397: bad argument #1 to 'strfind' (string expected, got nil)
stack traceback:
        [C]: in function 'string.find'
        citizen:/scripting/lua/json.lua:397: in upvalue 'scanwhite'
        citizen:/scripting/lua/json.lua:553: in function <citizen:/scripting/lua
/json.lua:551>
        (...tail calls...)
        server/main.lua:17: in local 'userCallback'
        citizen:/scripting/lua/scheduler.lua:318: in upvalue 'handler'
        citizen:/scripting/lua/scheduler.lua:219: in function <citizen:/scriptin
g/lua/scheduler.lua:218>
stack traceback:
        [C]: in function 'error'
        citizen:/scripting/lua/scheduler.lua:41: in field 'CreateThreadNow'
        citizen:/scripting/lua/scheduler.lua:218: in function <citizen:/scriptin
g/lua/scheduler.lua:182>

#2736

Error: Unhandled error in timer: Error: no such table: players
Error: no such table: players
at Database.handleError (C:\EG\serverdata\resources[scripts]\essentialmode\server\sqlite\sql.js:20:16584)
at Database.exec (C:\EG\serverdata\resources[scripts]\essentialmode\server\sqlite\sql.js:20:14832)
at doesUserExist (server/sqlite/sv_database.js:90:27)
at setTimeout (server/sqlite/sv_database.js:103:13)
at Object.callback (citizen:/scripting/v8/timer.js:96:21)
at onTick (citizen:/scripting/v8/timer.js:121:27)


#2737

For some reason I can’t set a job or set money it says invalid command or invalid interg I have superadmin permissions do have to set it in couchdb too with heidisql


#2740

So I just created the server and finally got it working. Now im trying to get Essentialmode working on it and it shows everything is good. I created a couchdb database and eseentialmode wont create the database for it to work.

Also, when I open the server and open the admin menu from essential mode, the server freezes and I have to shut it down.

Any ideas?


#2741

How do I setup a database?


#2742

Why is there no CitizenFX.log anymore or am I doing anything wrong? I have 6.0.2


#2743

I do not know if this has to do with essentialmode, but when I am going to change civilian clothes for work clothes, the weapons disappear and there is no way to recover them, any solution?


#2744

I update to the newest Essentialmode script now, but when I do that the es_admin2 commands not working.
Screenshot here

And yes. I am an ‘superadmin’ on the server.
If I wasn’t, it would say like no permissions. (No error in console or F8)
I have tried to update es_admin2 to newest too, but not working.

Edit: I use this chat https://github.com/Reknits/chat and my friends problem was just because of it. What is the thing who makes so it doesn’t work from the original chat?

Anyone have a fix?

/Ludvig. Thanks for the amazing build Kanersps! :+1:

72


#2745

I need help whenever i start server its shows :

[EssentialMode] Current version: 6.0.2
[EssentialMode] Updater version: 6.0.2

Access denied for command sets.
Access denied for command sets.
[EssentialMode] Everything is nice and updated!


#2746

Also cant see my ’ cash ’
Developers please take it serious …


#2747

if you r look to start up a database youtube


#2749

Please refrain from making “DM me on discord to fix your issues”. That is by far from helpful. Instead you should share the knowledge that led you to resolve your issue on this very topic.


#2750

@HavocIV
While SQLite exists, you should still use something different in production.

@Ludvig_Bartholdsson
I won’t help with any other “chat” resource. Use the built-in one, that’s the best currently available. It has theming to suit your needs.

@DavidMarston
Make sure to follow the installation instructions at the following link: https://wiki.kanersps.pw/display/FIV/Installation


#2751

Yeah. now fixed :grinning:


#2752

Hey.

Quick question, how can i change the starter cash? I tried looking for it like it says in the begin of the topic but i can’t find it :sweat:

Hope u can help me! :heart::heart: