[Release] EssentialMode base


#2454

Github shows latest change of 23 days ago and ES website shows 5.0.3 on it’s main page. Are users ok if they’ve updated within that time period?


#2455

Website download is latest anyway, they all link to the same download. Just didn’t update the page itself yet. And you’re only up to date if you downloaded it off github in that time period.


#2456

/admin or /noclip basically anything in the button options


#2457

Hey did u fixed it?

20 chars


#2458

Hey there gentlemen.

So I ran into a little problem and I was wondering if any of you kind souls would explain me what it happening over here.
I set up the server and essentialmode and when I start the server, everything goes fine until 5 seconds after I get a “[MySQL][Slow Query Warning]…” as show on the picture. (https://imgur.com/a/6kwfidC) Tried to find an answer for this on the forums but didn’t found a helpfull answer so I used this thread as last resort.
From what I little understand by reading the error, I believe it can’t find a DB called “essentialmode”. Is that the problem? Is there a way to fix it? If not, what is the error?

One thing I clearly didn’t understand. Do I have to have XAMPP running on the server where FiveM is (In this case a VPS) or?

Big thanks in advance and sorry for the incovinience.

Best Regards,
MiK


#2459

so i updated to the newest version of Essentialmode. The es_admin2 would be working just fine then out of no were when me or my admins try to kick or ban someone it will give all these errors.
Anyhelp?


#2460

Pls Help i become this error code

Access denied for command add_principal.
[ERROR] [MySQL] An error happens on MySQL for query “SELECT isDead FROM users WHERE identifier=@identifier {@identifier=steam:11000010c7e4339}”: Unknown column ‘isDead’ in ‘field list’


#2461

Pls help yourself, read what the error says. The column isDead doesn’t exist.


#2462

Hi guys, i have a big problem with my server :
When a new player try to join my server, the game freezes and he can’t create a character… he have to close the fivem process, then restart it, then join a second time and everything working good, he can create a character, and play.

Here is a screenshot of the bug in game :

As you can see, the minimap is not working, we can’t see any character skin too…

and, on the second connection everything is working :

So, i thought it was an addon failure, so i removed them all. In my server.cfg i only have :
start mysql-async
start essentialmode
start esplugin_mysql
start es_admin2
start es_extended
start nb_menuperso

In my server console, i don’t have any error
And here is my citizen.fx when i first join my server : https://pastebin.com/TKR1JwTY

Thank you very much, i hope someone can help me


#2463

The Field exist in the database


#2464

This is unrelated to essentialmode. Please contact the correct technical manager of that collection of lines for further assistance.


#2465

Hello everyone, today i worked on setup a new rp server, actually i already put some mods. It was working great, but i tried to install essentialmode with Mysql database, and here is the problem. I have installed correctly es_admin, essentialmode( I had before a message who tell me than essentialmode was ok). I have install MySQL-Async & esplugin_mysql, everything looks normal. My database is working, when i log in, it created me on the table “users” with an amount of money and bank money. The problem is when i log in, i can’t have any acess to this money, i don’t have any UI, i don’t have the message on logs server than told me than essentialmode is correctly setup and i have this:

[MySQL] [Slow Query Warning] [esplugin_mysql] [24756ms] SELECT * FROM users WHERE identifier =‘steam:XXXXXXXXXXXXX’; (I don’t see “XXXXXXXXXXXX” but my steam ID, the request is correct.)

[ERROR] [MySQL] [esplugin_mysql] An error happens on MySQL for query “[object Object]”: connect ETIMEDOUT

e[91mError: (node:318) UnhandledPromiseRejectionWarning: Error: connect ETIMEDOUT

at PoolConnection.Connection._handleConnectTimeout (mysql-async.js:1009:13)

at Object.onceWrapper (events.js:313:30)

at emitNone (events.js:106:13)

at Socket.emit (events.js:208:7)

at Socket._onTimeout (net.js:420:8)

at ontimeout (timers.js:482:11)

at tryOnTimeout (timers.js:317:5)

at Timer.listOnTimeout (timers.js:277:5)

at Protocol._enqueue (mysql-async.js:5807:48)

at Protocol.handshake (mysql-async.js:5714:23)

at PoolConnection.connect (mysql-async.js:720:18)

at Pool.getConnection (mysql-async.js:4577:16)

at Pool.query (mysql-async.js:4731:8)

at Promise (mysql-async.js:4970:12)

at new Promise ()

at execute (mysql-async.js:4967:26)

at Object.global.exports [as callback] (mysql-async.js:4993:5)

at citizen:/scripting/v8/main.js:87:41e[0m

e[91mError: (node:318) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)e[0m

If someone knows how i can correct this it would be wondefull <3


#2466

hey im having an issue using the es_admin2 everytime i use it by pressing home every pops up but when i try to do something it says: Access denied for command add_principal. i dont know if i have something configured wrong or not but even after if i close it the curser remains and i cant move in game


#2467

So I have had this issue for a while now, whenever someone joins my server for the first time they spawn as an npc (no job, no inventory, no phone etc)
I have no idea why and have contacted multiple coders and zaphosting asveel but nothing has worked. There is a table called user and everything is exactly like its supposed to be. Now I have to fill in each players user and my server is starting to grow rapidly so it takes a lot of time
Any form of support is extremely appreciated.