[Release] EssentialMode base


#2434

Since this isn’t an ES support question, it doesn’t belong in this thread but I will say that you’re going to find pretty much all of ESX is designed around MySQL and not CouchDB. If you want to roll with those particular resources, you will want to set up your server to utilize MySQL.

If you find yourself in need of help working it out, check out the ESX support thread and the ESX users discord.


#2435

When I use the /kick command in chat it comes up with this big error and does not work. I am using ZAP Hosting and have es_admin installed. How do I fix this?

"Error running call reference function for resource essentialmode: citizen:/scripting/lua/scheduler.lua:351: server/main.lua:234: attempt to index a nil value (field ‘?’) stack traceback: server/main.lua:234: in upvalue ‘ref’ citizen:/scripting/lua/scheduler.lua:337: in function <citizen:/scripting/lua/scheduler.lua:336> [C]: in function ‘xpcall’ citizen:/scripting/lua/scheduler.lua:336: in function <citizen:/scripting/lua/scheduler.lua:335> stack traceback: [C]: in function ‘error’ citizen:/scripting/lua/scheduler.lua:351: in function <citizen:/scripting/lua/scheduler.lua:322> "


#2436

Perfect! Thanks for the support. I will check in those support threads.


#2437

i keep getting this error


#2438

can i somehow translate it?


#2439

EssentialMode 5.1.0

  • Argument amount checks, like vanilla commands (Adds another parameter, count, to adding commands)
  • Argument count mismatch event handler
    Example:
    AddEventHandler('es:incorrectAmountOfArguments', function(source, wantedArguments, passedArguments, user, command)
  • Change event chatMessage to non-deprecated chat:addMessage
  • Removed random placeholder if statements
  • Removed random printing of debug data
  • es_admin2 cleanup, fixes and additions thanks to @Hawaii_Beach
  • Add tonumber() to some user input to make sure stuff doesn’t fuck up
  • Update manifest version
  • RCON command fixes
  • Move es_admin2 to seperate github repo
  • Fix es_admin2 when restarted would give everyone access to the admin GUI, now it works properly

#2440

HYPE we all have waited for this update


#2441

What are you typing to receive it?


#2442

EDIT: Nevermind … 20 chars


#2443

Yes you can.
Go to -> es_extended -> locales (edit the language you are using) [exemple: fr.LUA]

Or just specify the language in the config.LUA [ Config.Locale = ‘en’] <-- it will change to english.

I hope i’ve helped you :slight_smile:


#2444

I installed ESX and stuff like this (i followed a tutorial just 1 month old) and no error in my console. But when I type /admin there comes this error:

Error running call reference function for resource es_admin2: citizen:/scripting/lua/scheduler.lua:403: server.lua:310: attempt to index a nil value
(local ‘user’)

Do I have to install es_admin2 on client too? If yes pls tell me where

And how do I self give me admin

Btw: I have Essentailmode 5.0.3 idk how to update


#2445

You just have to overwrite the files and restart your server.


#2446

So I tried. The update is installed but it doenst work. Same error


#2447

I just updated essentialmode + es_admin and when I went into es_admin and closed it with ESC and the ‘X’ button I now cannot move around ingame or use any keys ingame.

FIX: Rename es_admin in es_admin2


#2448

Yepp, es_admin menu is stoping any input when pressing home button after closing the menu. You need to alt+f4


#2449

Rename es_admin in es_admin2 ?


#2450

I can’t align the amount of money to left. I cant see this property can someone help?


#2451

Where is the police cars replaced? How do I do it?


#2452

Yeah that worked. Thanks lol


#2453

I’ll rename it, if re-downloaded it should be fine again.

Edit: Might take a few more hours until renaming it internally is possible