[Release] ELS FiveM | Server Sync | Lights | Sirens | Custom Patterns


#827

MrDaGree, I don’t know what it was but its working again.

Thanks,
Eric


#828

hello,

When starting up the server i got this error. already tried reinstalling it…

Error running system event handling function for resource els-fivem: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: citizen:/scripting/lua/json.lua:397: bad argument #1 to ‘strfind’ (string expected, got nil)
stack traceback:
[C]: in function ‘string.find’
citizen:/scripting/lua/json.lua:397: in upvalue ‘scanwhite’
citizen:/scripting/lua/json.lua:553: in function citizen:/scripting/lua/json.lua:551
(…tail calls…)
server/server.lua:10: in local ‘userCallback’
citizen:/scripting/lua/scheduler.lua:318: in upvalue ‘handler’
citizen:/scripting/lua/scheduler.lua:219: in function citizen:/scripting/lua/scheduler.lua:218
stack traceback:
[C]: in function ‘error’
citizen:/scripting/lua/scheduler.lua:41: in field ‘CreateThreadNow’
citizen:/scripting/lua/scheduler.lua:218: in function citizen:/scripting/lua/scheduler.lua:182
i hope u can help me


#829

2 Things I’m having issues with.

  1. Can I configure something so that when I load the vehicle the pattern will be pre-selected at a pattern number? Numbers in the VCF xml doesn’t do this
  2. Only on some vehicles when I go to stage 3 the ELS panel disappears and I can’t get it back for any vehicle without restarting the resource… again only on certain vehicles, others work perfectly fine.

If anyone can help please do, thanks


#830
  1. never has been implemented 2) send me the VCF of the vehicle that breaks

#831

Ok, won’t send them all but heres a few:

One that works:
pd1.xml (5.2 KB)

Some that don’t:
so2.xml (5.4 KB)
so3.xml (5.4 KB)
so4.xml (5.4 KB)
so1.xml (5.4 KB)


#832

Any ideas?


#833

Honestly not too sure, Are you able to send screenshots of the F8 console?


#834

Not sure what im doing wrong but when i put an els vehicle as an addon the sirens dont work. i put the new name in vehicles and it doesnt work.


#835

Add-ons must have sirens setup and the emergency class for siren control to work


#836

Yes, here is it when the panel disappears:


Don’t know if that helps


#837

Restart the resource, perhaps the config isn’t being loaded for some reason.


#838

still doesn’t work even if I do that
Once it goes away its gone until I restart the whole server


#839

The VCF’s do not have environment color for the extras causing it to break. Please manually add this to the VCF.


#840

Ah that fixed it, thank you


#841

Had ELS 1.1.3 in my server and worked great. Then new update comes out and the panel shows up and everything but the lights don’t light up.


#842

The developer update has been out for a bit but not an actual release. We can attempt to help more on my discord or if you wish to send me screenshots in dm of your sever console and the f8 console while in a els vehicle


#843

could we get a new version?
or maybe i am understanding this wrong because i dont know what’s going on :joy:


#844

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


#845

my lights are really dim.
yes i have the most recent version.

image

image

image

any solutions?
every els car i use looks like this


#846

Install radiance v, has nothing to do with ELS