[Release] Disable seat shuffling

roleplay
release
vehicle
scripting
seat

#1

RELEASE | DISABLE SEAT SHUFFLE

Found and polished a lil script with help from vesupura.
But people wanted it to be made into a resource.

Enjoy!

HOW TO USE
As of the current latest version, the player will stay seated in the passenger seat. If you type /shuff, the player will shuffle into the driver seat.

CHANGELOG

  • 1.0.1
    By default, players will stay seated in the passenger seat. If you type /shuff they shuffle into the driver seat.
  • 1.0.0
    First version. By default the player will shuffle into driver seat, /shuffle enables and disables the script.

KNOWN BUGS

  • Sometimes the person will not shut the door when entering vehicle
  • Sometimes the player starts teleporting to the animation of switching seat then teleports back into passenger seat
  • Sometimes the door opens then closes while driving but very rare

DOWNLOADS
1.0.1
1.0.0


[SOLVED] JF_SeatShuffle
[Release] esx_personmeny
[HELP] Help with simple script(anti seat shuffle)
Cancel auto move to the drive seat
[HELP] Help with simple script(anti seat shuffle)
[HELP] Improving an existing script
#2

Sweet script wad just thinking of the time when you need guns but your passenger doesn’t. Nice to have them remain in the car :slight_smile: Nice work. Download seems to be broken. Says file damaged or wrong format.


#3

i swapped it round so it’s force true was gonna ask you to change it but then i realised i could just change it myself, but thanks for the script been looking for a antishuffle for a while


#4

is there a way we can make it so it enables automatically upon joining the server?


#5

change the bool from false to true?


#6

thank you for your help!


#7

What do you mean by this?


#8

@TotalChaoV2

Change

local antiShuffleEnabled = false

to

local antiShuffleEnabled = true

#9

Okay, I tried with the download version but it wouldnt work. so I pasted the client.lua you provided in this post


#10

What wouldn’t work? By default the script is disabled until you type /shuffle
that line i provided u is to make it enabled by default


#11

can you fix it so it does not teleport you back it just keeps in the seat


#12

It’s just a bug, happens sometimes.


#14

Wait. What does that mean?


#15

why not use: https://runtime.fivem.net/doc/reference.html#_0x30785D90C956BF35


#16

#17

That function is broken. At least it didn’t work when i tried it.


#18

That native just return if it is possible to shuffle seats in the given vehicle.


#19

@callmejaf The /shuff command in version 1.0.1 doesn’t shuffle me into the driver seat. It does nothing, but when I try to fix it, it breaks the whole script.


#20

I can assure you it works. I use it on my server now.


#21

@callmejaf Does the command require essential mode to be able to work?