[Release] Cops FiveM

roleplay
cops
police
#2403

Thanks for that info. I tried it, and same error. Username/password is correct, server is, database name, etc. And FiveM still gives the “unable to load resource ghmattimysql” error. Won’t show anything else. No error in the server startup at all. Loads everything.

Only other variable I can think is it hates windows 7 and demands windows 10

0 Likes

#2404

The fact that it still says unable to load resource ghmattimysql means that there is something wrong with your setup.

i just did a fresh install to be sure and couldn’t replicate the issue.

0 Likes

#2405

Tried a new way of installing everything, got the rest to work. go to install ghmattimysql and it throws this error. using the config file or deleting that and using the connection line in server.cfg still hurls the same error. Not making any sense!

edit: same error in FiveM about “cannot load ghmattimysql” Doesn’t make sense. I follow the directions to a T, configure the server, etc etc and it still tosses errors

C:\FXSERVER\server-data>
C:\FXSERVER\server-data>C:\FXServer\run.cmd +exec server.cfg
Error: unrecognized flag --typed_array_max_size_in_heap=0
Try --help for options
INFO: No channel links found in configuration file.
Found new resource esplugin_mysql in C:/FXSERVER\server-data/resources//esplugin
_mysql
Found new resource essentialmode in C:/FXSERVER\server-data/resources//essential
mode
Found new resource fivem in C:/FXSERVER\server-data/resources//fivem
Found new resource fivem-awesome1501 in C:/FXSERVER\server-data/resources//fivem
-awesome1501
Found new resource fivem-map-hipster in C:/FXSERVER\server-data/resources//fivem
-map-hipster
Found new resource fivem-map-skater in C:/FXSERVER\server-data/resources//fivem-
map-skater
Found new resource ghmattimysql in C:/FXSERVER\server-data/resources//ghmattimys
ql
Found new resource hatt in C:/FXSERVER\server-data/resources//hatt
Found new resource mysql-async in C:/FXSERVER\server-data/resources//mysql-async

Found new resource police in C:/FXSERVER\server-data/resources//police
Found new resource runcode in C:/FXSERVER\server-data/resources//runcode
Found new resource vMenu in C:/FXSERVER\server-data/resources//vMenu
Found new resource es_admin2 in C:/FXSERVER\server-data/resources//[essential]/e
s_admin2
Found new resource race in C:/FXSERVER\server-data/resources//[gamemodes]/race
Found new resource race-test in C:/FXSERVER\server-data/resources//[gamemodes]/r
ace-test
Resolved live-internal.fivem.net:30110 to 178.32.9.100:30110
Found new resource channelfeed in C:/FXSERVER\server-data/resources//[gameplay]/
channelfeed
Found new resource irc in C:/FXSERVER\server-data/resources//[gameplay]/irc
Found new resource obituary in C:/FXSERVER\server-data/resources//[gameplay]/obi
tuary
Found new resource obituary-deaths in C:/FXSERVER\server-data/resources//[gamepl
ay]/obituary-deaths
Found new resource playernames in C:/FXSERVER\server-data/resources//[gameplay]/
playernames
Found new resource mapmanager in C:/FXSERVER\server-data/resources//[managers]/m
apmanager
Found new resource vf_baseapps in C:/FXSERVER\server-data/resources//[phone]/vf_
baseapps
Found new resource vf_phone in C:/FXSERVER\server-data/resources//[phone]/vf_pho
ne
Found new resource baseevents in C:/FXSERVER\server-data/resources//[system]/bas
eevents
Found new resource chat in C:/FXSERVER\server-data/resources//[system]/chat
Found new resource chat-theme-gtao in C:/FXSERVER\server-data/resources//[system
]/chat-theme-gtao
Found new resource hardcap in C:/FXSERVER\server-data/resources//[system]/hardca
p
Found new resource rconlog in C:/FXSERVER\server-data/resources//[system]/rconlo
g
Found new resource scoreboard in C:/FXSERVER\server-data/resources//[system]/sco
reboard
Found new resource sessionmanager in C:/FXSERVER\server-data/resources//[system]
/sessionmanager
Found new resource spawnmanager in C:/FXSERVER\server-data/resources//[system]/s
pawnmanager
Found new resource betaguns in C:/FXSERVER\server-data/resources//[test]/betagun
s
Found new resource gameInit in C:/FXSERVER\server-data/resources//[test]/gameIni
t
Found new resource keks in C:/FXSERVER\server-data/resources//[test]/keks
Found new resource webpack in C:/FXSERVER\server-data/resources//[system]/[build
ers]/webpack
Found new resource yarn in C:/FXSERVER\server-data/resources//[system]/[builders
]/yarn
Started resource sessionmanager
Started resource mapmanager
Started resource chat
Started resource spawnmanager
Started gametype Freeroam
Started resource fivem
Started resource hardcap
Started resource rconlog
Started resource scoreboard
Started resource playernames
Started resource ghmattimysql
Loaded vMenuShared.net, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null in
to ScriptDomain_1019937135
Loaded vMenuServer.net, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null in
to ScriptDomain_1019937135
Instantiated instance of script GHMatti.Http.RequestInternal.
Instantiated instance of script GHMatti.Http.Request.
Instantiated instance of script vMenuServer.BanManager.
Loaded Newtonsoft.Json, Version=11.0.0.0, Culture=neutral, PublicKeyToken=30ad4f
e6b2a6aeed into ScriptDomain_1019937135
Instantiated instance of script vMenuServer.MainServer.
Instantiated instance of script vMenuServer.UpdateChecker.
Started resource vMenu
Started resource hatt
Started resource mysql-async
Started resource essentialmode
Started resource esplugin_mysql
Started resource es_admin2
Uncaught AssertionError [ERR_ASSERTION]: unexpected PromiseRejectEvent
internal/errors.js(102,11): AssertionError
assert.js(42,9): innerFail
assert.js(56,3): fail
internal/process/promises.js(27,25):
ghmattimysql.js(278,1556): orm.query
ghmattimysql.js(109,1512): Sequence.end
ghmattimysql.js(260,3884):
ghmattimysql.js(260,1314): onConnect
ghmattimysql.js(109,1512): Sequence.end
ghmattimysql.js(489,3184): Handshake.ErrorPacket

AssertionError [ERR_ASSERTION]: unexpected PromiseRejectEvent
Started resource police
Error: (node:8172) UnhandledPromiseRejectionWarning: Error: ER_ACCESS_DENIED_ERR
OR: Access denied for user ‘fivem’@‘localhost’ (using password: YES)
at Handshake.Sequence._packetToError (ghmattimysql.js:109:1148)
at Handshake.ErrorPacket (ghmattimysql.js:489:3136)
at Protocol._parsePacket (ghmattimysql.js:308:5471)
at Parser.write (ghmattimysql.js:314:1645)
at Protocol.write (ghmattimysql.js:308:875)
at Socket. (ghmattimysql.js:140:2050)
at emitOne (events.js:116:13)
at Socket.emit (events.js:211:7)
at addChunk (_stream_readable.js:263:12)
at readableAddChunk (_stream_readable.js:250:11)
--------------------
at Protocol._enqueue (ghmattimysql.js:308:2850)
at Protocol.handshake (ghmattimysql.js:308:1096)
at PoolConnection.connect (ghmattimysql.js:140:2921)
at Pool.getConnection (ghmattimysql.js:260:1073)
at Pool.query (ghmattimysql.js:260:3806)
at Promise (ghmattimysql.js:278:1421)
at new Promise ()
at execute (ghmattimysql.js:278:1386)
at Object.global.exports [as callback] (ghmattimysql.js:278:2014)
at citizen:/scripting/v8/main.js:87:41
Error: (node:8172) UnhandledPromiseRejectionWarning: Unhandled promise rejection
. This error originated either by throwing inside of an async function without a
catch block, or by rejecting a promise which was not handled with .catch(). (re
jection id: 1)
Error: (node:8172) [DEP0018] DeprecationWarning: Unhandled promise rejections ar
e deprecated. In the future, promise rejections that are not handled will termin
ate the Node.js process with a non-zero exit code.
Authenticating server license key…
Server lcfx> icense key authentication succeeded. Welcome!
Performing version check against: https://api.kanersps.pw/em/version?version=6.0
.2&uuid=23d0a508-dc0a-4c8a-843b-de8ddab3476a

Started map fivem-map-skater
Started resource fivem-map-skater
hitch warning: frame time of 434 milliseconds

[EssentialMode] Current version: 6.0.2
[EssentialMode] Updater version: 6.0.2

[EssentialMode] Everything is nice and updated!

[vMenu] Checking for updates.
[vMenu] Your version of vMenu is up to date! Good job!

0 Likes

#2406

is this for exs

0 Likes

#2407

no ESX has its own police resource, search the forum or look at github.

0 Likes

#2408

thank you for time dude

0 Likes

#2410

So I am having a problem understanding, so I need something other than the resource " MySql Async "

0 Likes

#2411

mysql-async isn’t required anymore, it has been replaced with ghmattimysql.

0 Likes

#2412

Quick Q, im looking to change each department’s clock on uniform to MP model pedvariations, i have no idea where i change that though…

0 Likes

#2413

Can we have a version that works with OneSync? Getting errors where it can’t find the nearest ped.

0 Likes

#2414

is really nice works well

1 Like

#2415

my server uses a old version of this that has worked fine for us for a while, but recently its not opening the f5 menu, any thoughts or help,(the reason we use the older versions is that we dont use my sql we use couch database)

0 Likes

#2416

Can anybody just send a download link with all this stuff included because i won’t work for me please.

0 Likes

#2417

Once Cuffed are they able to still walk themselves into the police station?

0 Likes

#2418

is anyone able to help me how i add attachments to the weapons ?

0 Likes

#2420

i having trouble i put mine all in and when i put CopAddAdmin it say so no commands

0 Likes

#2421

Can someone install the police resource I do not check it out so please contact me

0 Likes

#2422

Missing some important features. Check id, Jailer and searching players and cars. Anyone know where I can find a search script? Can’t seem to find one anywhere

0 Likes

#2423

any body can help me with this i got no errors only this?

image

0 Likes

#2424

The error is right in front of you :smiley:

Could not find dependency ghmattimysql
  1. Download the ghmattimysql from the repository release section.
  2. Extract the zipfile to /resources/ and make sure the folder is named ghmattimysql.
  3. Browse to /resources/ghmattimysql/ and open the config.json file and edit your database credentials

open server.cfg and add start ghmattimysql above start police

start mapmanager
start chat
start spawnmanager
start sessionmanager
start fivem
start hardcap
start rconlog
start playernames
start ghmattimysql
start police
0 Likes