[Release] Cops FiveM

roleplay
cops
police

#2195

Yes the author mentioned there is a bug with /coprank atm.


#2196

Ok so, I need to change the cloak room so that it is synced with ESX skin, the problem is that I tried to change the luas but it doesn’t(now it doesn’t even put the skin itself), so I need someone who knows how to do it explain it to me(and not just “oh yeah copy and paste this” I mean like WHERE do you have to paste?WHAT things you have to change, thank you


#2197

This script isn’t compatible with ESX, also that retarded framework has his own police script, use that instead.


#2198

if you’re talking about the Cops FiveM script, it does work with ESX. I have it on my ESX server. :slight_smile:


#2199

it does work

it isn’t using any features from ESX since Cops_FiveM is a standalone script.


#2200

i need a vehicle spawner for the cops…


#2201

how do you add a cop?


#2202

In client.lua comment out line 636 by putting two hyphens in front of it.

--ServiceOff()

Since the line number has changed several times, for future reference, I’ll post the below to search for:

		--Control death events
		if(config.useModifiedEmergency == false) then
			if(IsPlayerDead(PlayerId())) then
				if(alreadyDead == false) then
					if(isInService) then
						ServiceOff()
					end

@Kyominii How difficult would it be to make this an option in config.lua? If it only takes a few lines of code it might be worth adding.

@MLGPlasmaScope @MoravianLion and anyone else that’s still having the problem with the F5 key not working to open the menu, for me it was Toasty’s Cruise Control script that was breaking the F5, F6 and F7 keys. If you don’t use Toasty’s Cruise Control then try stopping scripts one-by-one until the F5 key works again.

@Fortnite_Fortnite_Ci Did you get everything sorted out? I think you were getting a few different commands confused with each other. To set the department you need to use “/copdept <ID> <department>” instead of “/coprank”. If you’re still having trouble the next paragraph might help you.

@Floxly I’m pretty sure this is already in the readme, but here’s how:
First make sure the “scoreboard” resource is running. While in-game, press the up arrow to bring up the scoreboard. This will show you your numeric player ID. Now in the console/RCON type this with the same capitalization and no quotes: “CopAddAdmin <ID>” Be sure to replace <ID> with your numeric ID from the scoreboard. After that you can type in the in-game chat “/copadd <ID>” to whitelist other players replacing <ID> with the ID of the player. “/coprank <ID> <Rank#>” will promote cops to the desired rank, which the numbers of each rank can be found in the readme. And “/copdept <ID> <Department#>” will set their department, the numbers of which can once again be found in the readme.

@Kyominii On the topic of the CopAddAdmin RCON command, is there a way to make it non-caps sensitive? I noticed a few people saying the command doesn’t work and I’m almost certain they’re typing it all lowercase.

Sorry for the massive post. I came back to report on the F5 issue and noticed the other questions I replied to. Hopefully I’ve helped at least one of you. :stuck_out_tongue:


#2203

Hello! Is possible to do some changes in config so never wanted lvl is active only when on duty? For me, it’s either never (never) wanted level or always wanted level


#2204

It is useModifiedEmergency config line

Good idea, please submit a ticket on github :slight_smile:


#2205


does anyone know how to fix this? I go into the cinematic and go into the garage and pick a vehicle, when I get out of the garage and get out of my vehicle. I am stuck in place. I cannot move or run or do anything, when I try to revive myself or kill myself, same thing happens. I have to disconnect and re-connect to fix it.


#2206

I have added a bunch of cops to the database and the config has the blips set to true but i dont see other cops on the map, am i missing something?

Thanks


#2207
useModifiedEmergency = false, --require modified emergency script

So if I set that to true, without the 3rd party script installed it acts the same as if I comment out the line I mentioned in my last post?

Edit: Nvm, I just saw issue #77 on GitHub. Is 2.0 the dev branch, or is it not public yet?


#2208

the dev branch contains 1.5 so i don’t think that 2.0 is public at this moment :frowning:


#2210

Is it possible to spawn police cars from this menu.
So can it be added ?


#2211

#2212

how would i change LSPD to Traffic and so on? please


#2213

still says i have no job ?


#2214

Hi!

Works fine, SQL is updated (I’ve checked everything 3 times), but still no those circles in cloakroom, armory nor garage… Any advice on this? :confused:

No errors whatsoever and I am highest rank in DB. :confused:

Thank you


#2215

I just installed it and it works fine for me, just says no job that’s it .