[Release] [ALPHA] "Arma III" Styled Missions


#222

No problem, take your time. :slight_smile:
There are a lot of changes yes. Which is why I just did some more playtesting. I just made another update
to 2.8.9 to fix ‘driving=true’, and a typo with the IsDefend missions, which will make them work again now .
http://www.mediafire.com/file/j5xfmj64twxbot5/mrp-missions-2.8.9.zip/file

here is the example of a zone for IsDefend (stop NPCs) mission… So you can make zones really large as well of course, by increasing the marker size and so the onscreen blip shows the zone to protect.
The zone markers I still need to tweak so they are always on ground level everywhere.



#223

you mean 2.9…
already did a 2.8.9


#224

here are the 2 changes I made:

in client.lua, line 3087, in function hasBeenConquered(MissionName):

change the line to:
if (DecorGetInt(ped, “mrppedid”) > 0 or DecorGetInt(ped, “mrpvpedid”) > 0) and (not IsEntityDead(ped)) and (DecorGetInt(ped, “mrppedfriend”) == 0) then

The change from
(not DecorGetInt(ped, “mrppedfriend”) )
to
(DecorGetInt(ped, “mrppedfriend”) == 0)

is important.

On line 1826…
Change the line to:
TaskVehicleDriveWander(Config.Missions[input].Vehicles[i].id2, GetVehiclePedIsIn(Config.Missions[input].Vehicles[i].id2, false), movespeed, 0)

Basically make sure it is using movespeed, as an argument not Config.Missions[input].Vehicles[i].movespeed


#225

did the last download link is already ok? with those change?


#226

yes, it has those 2 changes.


#227

First Test, Alone.

I start myself /mission Mission1
notarget
13 tagets missing (BLIP)
1 Hostage Missing (BLIP)
:frowning_face:

Test 2… Mission2 is on
I getoffline and getbak online…
Samething BLIP doesnt appear

Something Cool… Its Still Mission2
Before if 0 connect we where get back to Mission1 all the time.

I will edit this post


#229

lookingped
yes it does find them… and npc are there…
its blip target on map that not showing

When i start mission myself i can see for a tiny second that they try to appear (glitchy)


#230

thanks. Do no blips show even after 30 seconds? Do the blips blink on and off? or just briefly appear and not show again? Are you running any other mods that might conflict?
i just tested here, autostarted and blips showed fine after finding peds. Odd. Something is turning them off when you run it.


#231

Mission Pickup doesnt clean after another mission start.

Assasinate mission work they not auto stop as they did before

Ill check everything again to be sure its not my side


#232

I will double check mission pickups.

yeah, I would test with just this lua resource as a 3rd party add on to see if it works, to rule out conflicts, just in case.


#233

also when /stop mission Pickup doesnt clear mission Pickup anymore too…


#234

here a screenshot… i get back to 2.8.8 same mission…
Just to make you know that no other resource make them disapear.
8
Ill try your version without any modification from my side…
Just paste and play…
ill get back


#235

Ok, I see what is going on with MissionPickups…

In client.lua, where you see CleanupPickups(…,false) change that to CleanupPickups(…,true),
There will be 2 lines. That should fix it, it fixed it for me just now.


#236

2 line are now set to true
pickup clean up
npc cleanup
MissionPickup stay after next mission start
/stop doesnt clean them either
If i stop ressource they clean :wink:

i tried 2.8.9 Without any change… just copy/paste
Target Blip and Hostage Blip Not Appear either
Sorry


#237

for the blips… the line in the SpawnPedBlips event…
comment out the line:
if oldblip == 0 then
and add
if not DoesBlipExist(oldblip) then

instead.

also uncomment the lines inside the if statement there:

–print(‘ENEMY PEDT’)

–print(‘ENEMY PEDF’)

–print(‘ENEMY PED’)

let me know if that fixes it. If it didnt, let me know if you see any of those print statements in the console. thank you.

Will take a look at the pickups… these were definitely working fine in 2.8.8? I remember I put in a new fix for you to try in that version, but did not hear back, so presumed it was working.


#238

if oldblip == 0 then
and add
if not DoesBlipExist(oldblip) then

Now MissionPickup Cleaned up after mission and when /stop

Not sure what you want me to do with
–print(‘ENEMY PEDT’)

–print(‘ENEMY PEDF’)

–print(‘ENEMY PED’)

glitch
I have some luck … i was able to press printscreen at the same moment the target glitch for a little milisecond after mission start… that is what appear … and disapear fast


#239

basically remove the first two characters:
“–”
so
–print(‘ENEMY PEDT’)
becomes
print(‘ENEMY PEDT’)

this blip is still happening with the new line of code? or with the old line?
Is it just you online, or are other people joining?

If it still happening, and you remove the two characters, for the 3 print statements, let me know if the you see the ENEMY… text in the client console. thanks.

what is your server address/name? I may swing by to see what is happening.


#240

samething… nothing change really…

Something else…
When pick Mission pickup not disapear… second time i test it disapear!!!

And im not sure but it look like i have more ennemy that its suppose… look like more ennemy spawn

Now next mission doesnt start when finish one…
Sorry my dude something is wrong


#241

Do the npc blips not show on any mission now, or just the first mission?

What errors are you getting in the console? Also you can set blForceCheckForBlips = false to stop the NPC check loop and see if that helps.

Wierd, and you are testing the vanilla resource, with no extra edits? Again, let me know your server address when it is up next, and I can hop on sometime and see what is going on. Im testing locally against localhost.


#242

i start everything back…
with 2.8.9 fresh
ill do your recommendation for
if oldblip == 0 then
and add
if not DoesBlipExist(oldblip) then
and
blForceCheckForBlips = false

Cause it was starting to be worste… Mission not ending properly… or next mission not starting…
So il start your version clean without any change and ill set what you said.
After ill post what happen.

But for tonight ill be done after that … got to sleep work at 6am