No items in the shops.[ESX]

help
esx

#1

Recently added esx_foodtruck-master and now we have nothing left in the shops, how do i fix this ASAP? can still find the “shops” in the database https://gyazo.com/68a4a5feeeb6cdef74c0c04245d23558


#2

Hi, this is because in your database the name of the market are “market” but in the esx logic you need to put “LTDgasoline” or the other market name declared in the scripts


#3

I got it to worked somehow, but i really appericate you`re help!


#4

help no item shops


#5

You have the same issue as above. The markets are conflicting


#6

What part do I need to edit?
thank you


#7

Are you using the markets for anything? If not you should get rid of those.


#8

1 shop



#9

The only resource I know that uses a market is esx_foodtruck and I don’t see that in yours. Delete those markets from the table.


#10

thank you
mod esx_foodtruck


#11

I got the same issue could u help me?


#12

All items you want buy must be in items table.


#13

Yeah but how do i add them into items


#14

i made simple sql code

USE `essentialmode`;

INSERT INTO `items` (`name`, `label`) VALUES
('bread', 'Bread'),
('water', 'Water')
;

#15

I dont understand i did it with the items but didnt work, it works to give me bread and water but i cant buy it


#16

What items your shops table have


#17

It worked thanks alot dude! (:slight_smile:


#18

having the same issue however when i press e nothing happens not even an empty menu and when i try to go to another store/bar it doesnt even come up to press E no duplicates in databases however ther are four rows that say bar any help would be great


#19

How did you get this to work…


#20

can this be closed already, this should’ve been asked in the esx thread and not in a new one. also those 2 months bumps…