My Server Doesn't Show up! I can Direct Connect, but it doesn't show up in the list for anybody!

GTA V version?
1.0.1737.0
Up to date?
Pretty sure
Legit or Pirate copy?
Legit
Steam/CD/Social Club?
Steam
Windows version?
10 Pro-latest
Did you try to delete caches.xml and try again?
Yes
Error screenshot (if any)
None
System specifications
AMD Ryzen 2600
EVGA GTX 1060 3gb-No integrated graphics
ASUS ROG Strix B450-F Gaming
What did you do to get this issue?
Nothing; it’s just an issue
What server did you get this issue on?
My own-It’s called Nightseer Server
CitizenFX.log file
CitizenFX.log (151.2 KB) CitizenFX.log.1 (48.5 KB) CitizenFX.log.2 (13.3 KB) CitizenFX.log.3 (100.8 KB) CitizenFX.log.4 (117.0 KB) CitizenFX.log.5 (45.5 KB) CitizenFX.log.6 (93.0 KB) CitizenFX.log.7 (140.3 KB) CitizenFX.log.8 (99.0 KB) CitizenFX.log.9 (13.3 KB)
.dmp files/report IDs
I have no clue where those are

Okay listen, I have scoured everywhere for a solution to this issue and everything I’ve found so far has either been a “solved” and closed thread (not helping my issue) or just completely useless. Specifically, I can connect to my server via localhost, but the server doesn’t show up in the list and nobody else can connect to it. I also tried restarting everything and waiting 20 minutes and that didn’t help. YES I am giving heartbeats and I have TRIED to port forward, but I can’t tell if that’s the issue or not.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the FiveM community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

check your Port’s

TCP/UDP.

Can I get a good tutorial for that sort of thing? I have tried checking them with 30110 and 30120, but they’re both closed, even though I’m getting heartbeats. I’m using an AT&T router. Oh yeah, and when I did try and open them, it just didn’t work. I dunno which IP I’m supposed to be using because when I search Google for my IP, I get a very long string of letters and numbers which I believe to be IPv6.

Try this video: https://youtu.be/Smva0MA_g5o

General tips since it was a little difficult to see and understand what he was saying sometimes:

  • To find your local IP (for your router); Launch CMD (Command Prompt) and type in “ipconfig”, you need your IPv4.
  • If you don’t know your router’s login already, usually on AT&T routers it should be on the back, but otherwise a quick Google search will help you find what the login could be.
  • For your public/external IP address you can use: https://www.whatismyip.com/ (it shows both your public and local IPs by the way)
  • After you do everything and start your server, it may take a bit to show up in search so wait a few moments

Thank you! Will report back with results… hopefully results.

1 Like

Okay so… I tried it, waited for like half an hour and still nothing. I tried a port checker and it still says it’s closed! Now you did say to use IPv4 which I did use and I manually typed it into my router settings. I will send a few screenshots of the settings and maybe that’ll give some context.


It’s an AT&T U-Verse router; I don’t know the exact name of it, but if you or anybody recognize this, perhaps it helps. Also, Desktop-3OUT980 is my desktop, but shouldn’t it work if I type in the IP regardless?

Did you make sure to allow both connections through the firewall?

@anonymousbumblebee es, I did all the firewall stuff and before you ask, I’m getting heartbeats so that port somehow works.

1 Like

Does anybody else have tips for me?

its possible your ISP may not allow ports to be opened, mine did this but it was modem side so i got another modem to solve my problem, but sometimes its the ISP blocking it.

@Painwithin Well… dang, that sounds like it could be it. We do have a rather cheap internet plan and it is AT&T so… ya know monopolies. Thanks for that! I’m gonna wait for more explanations though.