"moon-island-uniform"

GTA V version?
= lastest
Up to date?
= yes
Legit or Pirate copy?
= legit
Steam/CD/Social Club?
= steam
Windows version?
= 10
Did you try to delete caches.xml and try again?
= yes i did
Error screenshot (if any)
= https://gyazo.com/ef4614b07000decc7d3d7515d2558103
System specifications
= 1080 gtx ti
What did you do to get this issue?
= I made a addon plane. When i go to to get into it, fivem crashes and gives me that error.
What server did you get this issue on?
= Development Server (personal)
CitizenFX.log file
= CitizenFX.log (170.1 KB)

.dmp files/report IDs
= none

Also add what you already tried so far.
= I have looked at the metas and made sure there correct.

You sure? did you look into “fivem application data”? (mostly located at %localappdata%\FiveM\FiveM.app )

i have one, its just a extreme amount of screenshots that would spam the post.

Just upload the file by dragging it into the editor

done [20 chars]

Having the same issue but with a Mclaren 675ltsp addon mod. Crashes as soon as I try to enter the car. :confused:

yes one of my cars doing it how to fix this

also having a issue with my car when i try get into it

Crashes as soon as I try to enter the car.

I get the same error when I try to enter Brian’s R34 and the Fairlady Z. Link to the mods are below.

I am also having this issue with some cars, as far as I can tell theres no reason for it. Anyone have a fix yet?

Im having this issue as well…

Having the same issue with right hand drive vehicles, any fix?

Has anyone been able to find out how to fix this issue?

Thanks in advance!

EDIT::

this issue is related to an issue with vehicle layouts meta file loader native

has to run in a separate _resource.lua

seems like if a _resource uses a Native data_file that has a location, the same _resource can not also send a data_file to a different location.

see below for more details

what the fuck?

this has nothing to do with ‘natives’ or directories or ‘files being put places’, you need to load the vehiclelayouts file in the right order, if you load it in the wrong order it of course won’t work since it doesn’t exist when the game asks for it.

1 Like

So what you’re trying to say is that, instead of taking the file out of the AI folder, I should drag the entire folder?

I am only specifically talking about using this in a _resource.lua on an fxserver

in said lua, the file is most certainly in the right order.
I believe the issue may be this:

A) the RHD layout file being used for most RHD is the same file copy pasted among everyone, and its written for a 4 door 4 seat vehicle. (makes problems with cars like the rx7)

C) the file has to be loaded after all the vehicles load

so my next test was going to be:
on a Subaru wrx sti that was an add-on and RHD from 5mods
remove the vehiclelayouts.meta and references to it from the cars _resource.lua
add it to a new _resource.lua using the 777 manifest version
edit out that line 4
start the new resource after all vehicles

ok finally got to test it and yeh figured it out.

good news! the NATIVE WORKS! Kinda not as expected

AGAIN, THIS IS ONLY RELEVANT TO RUNNING ON FXSERVER:

primary requirement: all vehiclelayouts.meta for all vehicles must be run in a separate resource
and that resource MUST be loaded AFTER all vehicles are loaded in the server start order.

example of that resource:

resource_manifest_version ‘44febabe-d386-4d18-afbe-5e627f4af937’

files {
    'vehiclelayouts.meta',
    'evo6/vehiclelayouts.meta',
    'jzx100/vehiclelayouts.meta'  
}

data_file 'VEHICLE_LAYOUTS_FILE' 'vehiclelayouts.meta'
data_file 'VEHICLE_LAYOUTS_FILE' 'evo6/vehiclelayouts.meta'
data_file 'VEHICLE_LAYOUTS_FILE' 'jzx100/vehiclelayouts.meta'

I can confirm its working on my server with 4 different vehicles that are all RHD addon vehicles, 2 of them are sharing the same layouts.meta, and the other 2 have their own layouts meta (you can tell if they are unique if you check the name of the layout in the vehicles.meta file or in the layouts.meta itself)

those working vehicles are:




as for the RX7 FD pandem, it appears to be trying to share the same layout as the wrx and the civic, but it may be a modified version of the original that the rx7 creator didnt change the name when he modified it. ill have to do more testing on that car specifically to figure out whats wrong for sure, but it still crashes.

also, im not sure if it will make a difference with other vehicles, but with all these vehicles I am using the newest resource manifest version number 44febabe-d386-4d18-afbe-5e627f4af937

anyway hope this helps somebody

drive fast and take chances :wink:

ok final update, got it all working with vehicles installed in a single resource, layouts and vehicle_names.lua in a second resource.

EVEN THE RX7 WORKS NOW with the shared LAYOUT_LOW_RHD

vehicles resource example:

resource_manifest_version '44febabe-d386-4d18-afbe-5e627f4af937'

files {
    
    --jzx100    
    'cars/jzx100/vehicles.meta',
    'cars/jzx100/carvariations.meta',
    'cars/jzx100/carcols.meta',
    'cars/jzx100/handling.meta',
    'cars/jzx100/jzx100contentunlocks.meta',
}
--jzx100
data_file 'HANDLING_FILE' 'cars/jzx100/handling.meta'
data_file 'VEHICLE_METADATA_FILE' 'cars/jzx100/vehicles.meta'
data_file 'CARCOLS_FILE' 'cars/jzx100/carcols.meta'
data_file 'VEHICLE_VARIATION_FILE' 'cars/jzx100/carvariations.meta'
data_file 'CONTENT_UNLOCKING_META_FILE' 'cars/jzx100/jzx100contentunlocks.meta'

files {
    --evo6    
    'cars/evo6/vehicles.meta',
    'cars/evo6/carvariations.meta',
    'cars/evo6/carcols.meta',
    'cars/evo6/handling.meta',
    'cars/evo6/evo6contentunlocks.meta',
}

--evo6
data_file 'HANDLING_FILE' 'cars/evo6/handling.meta'
data_file 'VEHICLE_METADATA_FILE' 'cars/evo6/vehicles.meta'
data_file 'CARCOLS_FILE' 'cars/evo6/carcols.meta'
data_file 'VEHICLE_VARIATION_FILE' 'cars/evo6/carvariations.meta'
data_file 'CONTENT_UNLOCKING_META_FILE' 'cars/evo6/evo6contentunlocks.meta'

files {    
    --gdwrxsti    
    'cars/gdwrxsti/vehicles.meta',
    'cars/gdwrxsti/carvariations.meta',
    'cars/gdwrxsti/carcols.meta',
    'cars/gdwrxsti/handling.meta',
}

--gdwrxsti
data_file 'HANDLING_FILE' 'cars/gdwrxsti/handling.meta'
data_file 'VEHICLE_METADATA_FILE' 'cars/gdwrxsti/vehicles.meta'
data_file 'CARCOLS_FILE' 'cars/gdwrxsti/carcols.meta'
data_file 'VEHICLE_VARIATION_FILE' 'cars/gdwrxsti/carvariations.meta'

files {    
    --eg6    
    'cars/eg6/vehicles.meta',
    'cars/eg6/carvariations.meta',
    'cars/eg6/carcols.meta',
    'cars/eg6/handling.meta',
 
 }
 
--eg6
data_file 'HANDLING_FILE' 'cars/eg6/handling.meta'
data_file 'VEHICLE_METADATA_FILE' 'cars/eg6/vehicles.meta'
data_file 'CARCOLS_FILE' 'cars/eg6/carcols.meta'
data_file 'VEHICLE_VARIATION_FILE' 'cars/eg6/carvariations.meta'

  files {    
    --FD    
    'cars/FD/vehicles.meta',
    'cars/FD/carvariations.meta',
    'cars/FD/carcols.meta',
    'cars/FD/handling.meta',
 
 }
 
--FD
data_file 'HANDLING_FILE' 'cars/FD/handling.meta'
data_file 'VEHICLE_METADATA_FILE' 'cars/FD/vehicles.meta'
data_file 'CARCOLS_FILE' 'cars/FD/carcols.meta'
data_file 'VEHICLE_VARIATION_FILE' 'cars/FD/carvariations.meta'

and then the vehicle layouts resource example:

resource_manifest_version '44febabe-d386-4d18-afbe-5e627f4af937'

files {
    'vehiclelayouts.meta',
    'evo6/vehiclelayouts.meta',
    'jzx100/vehiclelayouts.meta'  
}

data_file 'VEHICLE_LAYOUTS_FILE' 'vehiclelayouts.meta'
data_file 'VEHICLE_LAYOUTS_FILE' 'evo6/vehiclelayouts.meta'
data_file 'VEHICLE_LAYOUTS_FILE' 'jzx100/vehiclelayouts.meta'


client_script {
    'vehicle_names.lua'    -- Not Required, but you might as well add the cars to it (USE GAMENAME not ModelName)
}

that should do it. just make sure the layouts resource starts directly after the vehicles resource. :slight_smile:

@N3ON1: also now have got both of those vehicles working with same method / same asset. (the Fairlady z and brians r34 working great)

I dare say any vehicle should work now.