Latest server version doesn't work on linux [mono]


#1

It’s just plain broken. Missing DLL’s (seems all of the DLL’s from “bin” are now gone, though it only complained about Newtonsoft.Json, Nlog and uhttpsharp). Moved those DLL’s from the bin folder (from the previous version, since they’re no longer included in the download), and get

Missing method .ctor in assembly /…snip…/CitizenMP.Server.exe, type YamlDotNet.Serialization.Deserializer
2016-10-31 02:20:52.4452|FATAL|CitizenMP.Server|Could not open the configuration file citmp-server.yml.

Tried moving YamlDotNet DLL from bin to root but it doesn’t seem to be the right version anymore?

Can we please get a fresh server zip with all the files included in the right place so we can actually use fivereborn again?


#2

Did you try the latest one? As from yesterday evening?


#3

Don’t move/replace any DLLs, make sure you’re on the latest Mono 4.6+, and it should work out of the box.

I literally have no clue why you’d think you should move/put in such DLLs :confused:


#4

@leaf said in Latest server version doesn't work on linux [mono]:

Don’t move/replace any DLLs, make sure you’re on the latest Mono 4.6+, and it should work out of the box.

I literally have no clue why you’d think you should move/put in such DLLs :confused:

Because they’re all missing and the EXE is looking for them.