Interior building problem


#1

Hi guys, I have some trouble with my es_roleplay gametype, essentially when I’m using mine es_roleplay some interiors doesn’t show up, but using es_freeroam it will be.

Can someone help me?
Thanks a lot


#2

I think you need the open interiors mod.


#3

I tried it and it works, but the problem is that I want to stick to have DisableScriptHook setted as true, because I don’t want to let users use LambdaMenù on my server


#4

Maybe there is a native to load interiors?


#5

I tryied to find it onto the forum but I didn’t found anything, could you help me? :slight_smile:


#6

I can’t really help you at the moment because my pc doesn’t have Internet right now. But what I would do is look for a native that loads an interior. Run that function on player or server start then maybe use IS_INTERIOR_READY to check and if not reload the interior so that it’s good to go.


#7

Hey, I tryied to understand how do what you mentioned before, but I didn’t find any reference to do that :frowning:


#8

I have never had to do this before. Go on the discord and see if they can help you.


#9

Free roam loads certain ipl’s
Not sure roleplay game mode has ipl’s integrated.

Search missing ipl’s you can load them and it will fill in the missing parts of the map

Check this


#10

Finally I found the problem, I didn’t import my map.lua…I’m dumb as fuck! ahah thanks you guys


#11

Eh your not dumb. Just a mistake.


#12

I am new to setting up a server and I have this issue as well, but I don’t understand what you meant whey you stated about the import of the “map.lua”

Any help is greatly appreciated.

Thanks.


#13

Watch how es_freeroam works, in the _resource.lua is mentioned a client script called map.lua, inside it there is all you need for the interior builind


#14

Thank you very much. Will take a look at that now.

Edit: That fixed it, I didn’t know what ipl’s I needed, but they were all there.


#15

Glad you guys figured it out.