[help] /setjob error ESX


#1

okay when I type /setjob [ID] [jobname] [jobgrade] I get this error. I use to never get this error. It randomly just started and I do not know what to do. When I go to the job center and ad a job its fine. It is only when I enter a job with the command. Could someone please help. Thank you!


#2

A variable named xPlayer does not exist. Please ask for support in the original topic next time.


#3

make sure you are seting the /setjob with the correct variables


#4

I am setting the correct variables. I went into the server folder to the commands.lua in es_extended and this is what I found.


Do you know what I need to do to correct the problem?


#5

You’re likely feeding it the incorrect player ID.


#6

I added the correct player id and I am still receiving the same error. I even rebuilt the database thinking something got deleted and I am still receiving the same result. I am completely at a loss on what to do?


#7

This is how it fully looks. My ID is 1 because I just started the server and entered the command in.