Help please!


#1

I have been working through many issues today just to come to a new one finally solved what I thought was the last issues only to find I have issues I have

no idea how to fix XD any help is appreciated!


#2

So from just reading the error, it mentions a resource named: esx_weashops

I would suspect that, the resource named “esx_weashops” is causing those errors.


#3

Error running system event handling function for resource essentialmode: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: server/db.lua:208: attempt to index a nil value (field ‘docs’)
stack traceback:
server/db.lua:208: in upvalue 'callback’
server/db.lua:84: in local 'userCallback’
citizen:/scripting/lua/scheduler.lua:274: in upvalue 'handler’
citizen:/scripting/lua/scheduler.lua:175: in function citizen:/scripting/lua/scheduler.lua:174
stack traceback:
[C]: in function 'error’
citizen:/scripting/lua/scheduler.lua:41: in field 'CreateThreadNow’
citizen:/scripting/lua/scheduler.lua:174: in function citizen:/scripting/lua/scheduler.lua:138

this is the new error now


#4

essential everythign is causeinmg errors i removed several others that were causeing errors but i dont want to remove this


#5

Dont use essentialmode than if it doesnt work/or you cant get it to work??


#6

its required for alot of scripts is my problem


#7

Such as? Have you tried vRP?


#8

i beleive jobs propertys and police mod ill look into vrp


#9

I know this is old, but just for future reference, the culprit was an older version of CouchDB. You have to be on 2.0.0 or higher for essentialmode to work. Hope this helps someone down the line :slight_smile: