[HELP] error


#1

Error running system event handling function for resource esx_society: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: server/main.lua:39: attempt to index a nil value (field ‘?’)
stack traceback:
server/main.lua:39: in upvalue ‘handler’
citizen:/scripting/lua/scheduler.lua:175: in function citizen:/scripting/lua/scheduler.lua:174
stack traceback:
[C]: in function ‘error’
citizen:/scripting/lua/scheduler.lua:41: in field ‘CreateThreadNow’
citizen:/scripting/lua/scheduler.lua:174: in function citizen:/scripting/lua/scheduler.lua:138
how to fix?


#2

Theres an error in

it failed to run

The 39 probably means line 39.

happens if you have edited wrong or from bad coding.

Look through it


#3

i havent edit somthing in there


#4

Oh well look in server/main.lua look on line 39 see if there’s anything out of the ordinary.

Check the resources original source code on github or whatever it’s on.


#5

i see no difrence so i cant understand why i get this type of error


#6

Well ask for some extended help in the scripts topic, where you can talk to the Dev of it.


#7

can you do it for me


#8

I don’t use frameworks and have not many ideas on them. Ask in the original thread and you can get better help as the Dev of it will be able to help. Otherwise if it’s a bigger issue try reinstalling it as a fresh copy of the script if it still does not work it could be outdated and does not work properly.


#9

thx for helping i got another script and edited and it worked thx dude please take this post down


#10

No need to take it down. It can help others with the same issue…