[HELP] Add-On Boat


#1

I tried adding boats the same way I add cars and I keep getting this error when I attempt spawning the vehicle.error If you know how to fix the error please tell me


#2

Whatever boat model you tried using is not good… Try finding another one.


#3

I had that with 3 models now.


#4

Eat, Sleep, Try another boat, Repeat.


#5

tried the same thing, sadly RSMods, one of the creators of the sea ray yachts doesnt have an idea about fivem so he cant help at the moment…
i tried every yacht that i could find (there arent alot of ships avaible as mod/addon, also some that arent from RsMods) but none of them are working… only some military and coastguard ships worked…

i think it has too much polygons or something?
Im pushing this thread while hoping that somebody has an idea how to fix this…


#6

Hello!

I had the same issue. I just converted this one but I’m not home and can’t test it.

Try it and let me know if this works.

Download


#7

Think many of the boat/yatch skins are to files that are to big for fivem to handle. But im not sure, i can only get smaller boats and jet-ski to work.
Those driveable yatch never seem to work for me at least.


#8

I think texture files cap for boats is the same as any other vehicle (16mb), I tried once to convert a boat before this one and I got assets errors. So the problem is not the streaming, issue starts within the model file I guess.

Dunno if the one I just converted here works for you all, I’ll try it tonight when I’m home but I think it won’t.


#9

Let us know, you be nice to have one that accually works.
But i will say try looking on the comments on the boats before downloading, i can see that “alot” is complaining. Saying that they are wrong to call them addon boats when they are accually replacements in some way.
Dident get 100% into it, but maybe worth looking at.

But i hope i work for you :slight_smile:


#10

@BorgoMadonno:
i tried your file, the yacht doesnt work sadly.
when i try to spawn it in fivem, the client is crashing with the following error:

yachterror


#11

When someone write [Add-On] I always expect the texture files have names of models that are not in the basic GTA V.

I read “yacht4” and honestly I never heard about that in the GTA V files. Maybe I’m wrong. If it’s the problem I would try to rename “yacht4” in like “newboat123” to be sure to not spawn any vehicle that already exists in GTA. But I find it very hard to think no one of the ppl who complain ever tried to do it.

Btw I give it a try tonight. Nothing guaranteed.

Sorry about that. As I said I already got that error so the problem is boat not properly streamed. I’ll try rename it tonight in every file to be 100% sure of what I’m saying.


#12

This happens when a model is exported with a broken export tool, such as old versions of ZModeler and/or GIMS V.

Tell the author to re-export it with a newer version of the tool they used.


#13

thank you for the hint!


#14

Ok didn’t work at all.

I asked him to fix on the yacht page. Hope he will.


#15

can we fix this on our own in some way? or are these files are not able to be changed/fixed from other then the autor?