Gta 5 default tow truck hook problem

towing

#1

To receive support, please fill out the following template, and remove this top text.

GTA V version?
**Up to date?**yes
**Legit or Pirate copy?**legal
**Steam/CD/Social Club?**steam
**Windows version?**10
Did you try to delete caches.xml and try again? i dont think its a problem with myside
Error screenshot (if any)
System specifications
What did you do to get this issue? tried using the default tow truck to pick up a truck
What server did you get this issue on? American Force Gaming Private 2
CitizenFX.log file
.dmp files/report IDs

Also add what you already tried so far.
When roleplaying a truck impound I had to use the default tow truck (large tow truck FYI) hooked up fine 1st try then about 500ft it disconnected on its own. Then after that it took a half hour to get it rehooked up and moved to the station (after about 20 disconnects). I understand there might be a syncing issue to where that could be the problem but I saw someone make a tow truck and it worked without having any sync issue. Long story short is there a way to fix the tow hook?