FXServer is blocking a command?


GTA V version? not relevant
**Up to date?**yes
**Legit or Pirate copy?**legit
**Steam/CD/Social Club?**steam
Windows version? not relevant
Did you try to delete caches.xml and try again? not relevant
Error screenshot (if any)
System specifications not relevant
What did you do to get this issue? not relevant
What server did you get this issue on? not relevant
CitizenFX.log file not relevant
.dmp files/report IDs not relevant

Hi, I FXSERVER seems to be blocking some commands executed in the ExecuteCommand() function

   23: 	ExecuteCommand('add_principal identifier.' .. self.license .. " group." .. self.group)

returns this error in rcon:
Access denied for command add_principal.

Any help is appricated.

CMD Error?

Moved to #development:scripts.

Are you trying to execute that code on a client script or a server script?
I believe client side scripts don’t have access to those commands because the executing client might not have permission to use /add_principal.

Try enabling dev/debug commands using your client console and check what messages are being logged when you execute that code you provided. It should log all “permission” checks and you should be able to find out what the executing permission group is.


It’s part of Essentialmode 5.0.0, it’s certainly being ran on the server as it’s in the server folder of essentialmode.


Alright I think I know what the issue is. Because it’s being executed by a resource - it’s also executed by the system.console group but FIRST it’s executed as your resource - you need to make sure that you allow that resource to execute that command.

So in your permissions section in your server.cfg file make sure to put something like this:

add_ace resource.<resourcename> command.add_principal allow

Edit: I’m not 100% sure if this will work, so correct me if I’m wrong :wink:


Hi, I added that to my config, and I no longer get the error, but I get stuck on Initalizing session (due to the fact Essentialmode runs that command when I connect.)


You’ll have to ask @Kanersps in the essentialmode topic for that, not sure what happens when that command is executed.


Alright thanks for the help anyway.


Hi again, after talking to Kanersps I decided to disable all resources I installed. Here’s my server.cfg config:

Server boot log:

But now I get stuck on Initializing session like before but without the Access denied error?!

Server is ubuntu linux.


because you didn’t load any map, seemingly as you edited fivem-map-* resources


Yeah, I did I thought I had to change something on hipster and skater, I changed it back, or atleast I thought I did, could you send me the original __resources.lua for hispster and skater please?


Nevermind, sorted.

Thanks everyone.


It’s available here: https://github.com/citizenfx/cfx-server-data


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.