FXServer - Couldn't find resource xxxxxx^7


#1

To receive support, please fill out the following template, and remove this top text.

GTA V version? 1.42 (build 1290)
Up to date? Yes
Legit or Pirate copy? Legit (Rockstar version)
Steam/CD/Social Club? Yes
Windows version? Win10 64-bit (1709/ 16299.125)
Did you try to delete caches.xml and try again? Haven’t succeed so far, lol
Error screenshot (if any)
Couldnt find resources
System specifications
What did you do to get this issue?
What server did you get this issue on?
CitizenFX.log file

[ 0] Initializing Mono
[ 16] Initializing Mono completed
[ 16] Hello!
[ 94] ^3Couldn’t find resource sessionmanager.^7
[ 109] ^3Couldn’t find resource mapmanager.^7
[ 109] ^3Couldn’t find resource chat.^7
[ 109] ^3Couldn’t find resource spawnmanager.^7
[ 109] ^3Couldn’t find resource sessionmanager.^7
[ 109] ^3Couldn’t find resource fivem.^7
[ 109] ^3Couldn’t find resource hardcap.^7
[ 109] ^3Couldn’t find resource rconlog.^7
[ 109] ^3Couldn’t find resource scoreboard.^7
[ 109] ^3Couldn’t find resource playernames.^7
[ 125] Authenticating server license key…
[ 422] Server license key authentication succeeded. Welcome!
[ 484] Resolved live-internal.fivem.net:30110 to 151.80.44.223:30110
[ 484] Sending heartbeat to live-internal.fivem.net:30110

.dmp files/report IDs

If an issue with starting:
GTA V folder screenshot
GTA V/update/x64/dlcpacks screenshot
Filepath to FiveM folder I am very interested in the folder structure and I think my problem is just here.
FiveM client folder screenshot Planning to host dedicated server…
Did you try to disable/uninstall your Anti-virus? No

Also add what you already tried so far. I have build this dedicated server found here: https://wiki.fivem.net/wiki/Running_FXServer. I think my problems is just the structure of folders. My run.bat looks like this:

—8<-----Run.bat-----------------------------------------

cd /d "c:\GTAV\FXServer\server-data"
C:\GTAV\FXServer\run.cmd +exec server.cfg

--------Run.bat---------------------------------->8-------

And the folder structure:

GTAV
L__cfx-server-data-master
L__FiveM
L__FXServer
… L__citizen
… L__server-data
…L__cache
L__server-data (dublicate??)
… L_cache
L__ReadMe
L__update
L__x64


#2

I know that if you set a start.bat folder in the server folder you have and then do like this in it:

C:\XXX\XXX\XXX\run.cmd +exec server.cfg

It should work If it doesn’t pm me and we can talk to make it more clear later on.


#3

Hi!

I solved this ‘Couldn’t find resource’ -problem.

  1. no need to have FiveM and GTA V files on server (LOL)
  2. only this three folders needed inside the FXServer: cache, citizen and resources

I had too many folders and wrong files on there. Like cfg-server-data-master and server-data. Wiki page instructions in line 7 was the wrong information to me. It says to have server-data folder in FXServer:

  1. Run the server from the server-data folder. (cd /d D:\FXServer\server-data)

On line 5 I understand that I have to put my folder ctx-server-data-master files inside FXServer. :wink:

Lucky I found a YouTube video and all was clear. Those files inside ctx-server-data-master files just went to FXServer - not the folder itself.

Yep, too mystical instructions to my mind there on Wiki page.

Now is the next step to take and find how to install all those rp mods there. The blanco FiveM world was boring. :smiley:


#4

Hey there can I get help on the same error too? But mine’s just “couldn’t load resource /”


#5

Hi!

You can watch this YouTube video: How To Create a FiveM Server (FXServer)

(Seems people use default file name in FileManager and Windows hide those known filetypes. You can disable this on your Control Panel: uncheck “Hide known file types”.)

In my case I had just wrong folder structure.

I have advanced the case and the founding already ESX servers, so I have two different servers for them: Perus (Basic) and ESX.

Here is my folder structure about FiveM FXServer:
2017-12-31_024628
Here you see that my server.cfg file is located there on “server-data” folder.

And here is my ServerStart.bat file located in \FXServer folder:

cd /d C:\FXServer\server-data
c:\FXServer\run.cmd +exec server.cfg
(I just removed world “Perus” to copy and paste to your own batch file)

At last you need the server licence key from here and but it your server.cfg file (bottom of it):
https://keymaster.fivem.net

And in my case, behind NAT, I have jost port forward the ports between 30110 - 30120. You just need to surf your router URL like 192.168.0.1 and do your magic.

I have one question. There on server.cfg is this values. I have the Rockstar version, not the Steam. If I use this kind of settings I cannot log in, even my my Steam client is open and I am logged in. This mean I cannot play on FXServers? Rockstar piracy protection is the Social Club -system and Steam maybe need just logged in. FiveM servers now believe I am the “bad guy/ pirate version user”?

# want to only allow players authenticated with a third-party provider like Steam?
sv_authMaxVariance 1
sv_authMinTrust 5

(Uh, the font is big because of this “#” mark, eh.


#6

I thought this for a long time. However I was informed by a moderator that it’s untrue. All you need is a legit copy of gta5 and a steam account with steam running. You don’t have to buy gta5 on steam. However if your having an issue might want to get a mods attention. Because most servers (including mine) require steam to be running.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.