FiveM update "breaking?" the use of Extra_'s or looped functions?

Okay so myself / my community among many others using this script have noticed an issue that started for us all at the same time - A FiveM update (Around the time scheduler.lua was updated, so here ) broke the way an ELS script worked (see HERE or HERE ).

To reproduce: take THIS resource with this car model (any model setup for ELS will work fine), use the defined key binds to set the pattern / stage “on”, then use that same key bind to turn the pattern / stage off, resulting in: THIS (See the POLICE - STOP board, see how it flashes after being turned off?).

I’ve gone through the code and honestly can’t find why specific functions of the script have stopped working. It’s as if the game doesn’t know if the loop is finished or not. Before people ask if i’ve tried troubleshooting it, it worked fine before the update, and even then, i’ve restored backups and completely fresh installs of the script without modifying anything - it always results in the same.

Anyone got any ideas / advice?

Advised to post this by a snail