FiveM server crashing and deleting files, help fast

It’s not about the game or fivem launcher…
It’s about my server…
First when I try to launch it for the first time everything loads, no errors or bugs are showed. Then everything stops and deletes run.cmd and the start launcher. And after that when I try to extract run.cmd again it won’t let me do it. Restarted the PC, then I try it again. Everything is cool atm after I try to lauch it.

‘D:\FXServer\FXServer’ is not recognized as an internal or external command,
operable program or batch file.

However I checked many times and there is not \ between FXServer or anything like that…

Here’s the start launcher command:

And when I delete all files and making everything again. This time I didn’t put a license key in server.cfg. It showed a error but this time run.cmd and the start launcher did not get deleted. After I set-up the key in server.cfg showing me again everything loads and then crashing the cmd and auto-deleting the files again. Is there any solution… Sorry if this is the wrong sub-forum.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the FiveM community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

I am not too sure where you are getting your files from, however:

echo -
echo FXServer VRP
echo -

Is not part of the Documentation, and it sounds like you are using some kind of prepacked server setup.

I would suggest, if you have not done so already, that you follow the FiveM Documentation step-by-step; then you can worry about install Resources, such as VRP.

So I tried that. Doesn’t show anything. It’s like starting it from run.cmd but nothing is working. I don’t even see a cmd pop out.
I’m using the latest,, and vrp framework.
Here’s my folder:

I followed everything from the wiki. Btw i forgot to mention… when I create a simple FiveM server without vrp or other scripts. The server is working fine no deleting files etc…

Then the issue likely lies with VRP, if you can run a normal server with no issues. I would suggest contacting them for help, see if they know why this is happening.

I’ve searched the folder for vrp framework and I see there’s a server.cfg. But there’s not a license key line or something like that or how many players I can set the server to.

VRP Framework folder:

Where did you get the VRP.cmd file from?

You are using a two-year-old, outdated, framework - no wonder it is not working.

Have you considered using the most up-to-date version instead? You are bound to have a lot more luck with it:

I will try that one I will let you know if something happens

this time when i try to launch the launcher the cmd doesn’t even show up. But when I try running run.cmd the server is showing up. But I get this error:

I’ve entered the key in the server.cfg and nothing happens I get this error again and again

What file are you using to run the server? Can you also copy the contents of that file here please.

Created a text file named it start.cmd with this start command that you gave me:


I did not give you a start command, I quoted from your own file.

You need a .cmd file that executes the run.cmdfile as well as the server.cfg file, such as the one listed in the Documentation, for example:

cd /d D:\FXServer\server-data
D:\FXServer\server\run.cmd +exec server.cfg

You need to change the above for your own dicectories.

this code goes to start.cmd? I have never done anything like this.

No. Please refer to the Documentation:

Run the server from the server-data folder. For example, in a plain Windows command prompt (cmd.exe) window:

cd /d D:\FXServer\server-data
D:\FXServer\server\run.cmd +exec server.cfg


You don’t have a server-data folder so cd to your FXServer folder, however i suggest you put your resources and config and other stuff in an seperate folder

Can you give me all the file names that should be in server-data folder?

Minus the .git, the .gitignore and the myLogo.png files.