FiveM on linux won't start


#1

Hello. I’ve followed the instructions to the letter, but am still unable to start a FiveM server: Errors are below:

proot error: execve("/opt/cfx-server/FXServer"): Permission denied
proot info: possible causes:

  • the program is a script but its interpreter (eg. /bin/sh) was not found;
  • the program is an ELF but its interpreter (eg. ld-linux.so) was not found;
  • the program is a foreign binary but qemu was not specified;
  • qemu does not work correctly (if specified);
  • the loader was not found or doesn’t work.
    fatal error: see proot --help.

-rwxr-xr-x 1 root root 178328 Dec 4 19:59 /opt/cfx-server/FXServer


#2

You/the program does not have permissions to open FXServer, Look throw that before u ask here.


#3

yeah I get that… I’m running as root, so it’s not a user permissions issue, and from the FXServer permissions, it’s set 755 (executable).


#4

well it is still a permission issue as it states question is why, try giving it 777 to see if it stops saying permission denied.


#5

[~]# chmod 777 /home/five5/server/alpine/opt/cfx-server/FXServer
[~]# bash /home/five5/server/run.sh +exec /home/five5/server-data/server.cfg
proot error: execve("/opt/cfx-server/FXServer"): Permission denied
proot info: possible causes:

  • the program is a script but its interpreter (eg. /bin/sh) was not found;
  • the program is an ELF but its interpreter (eg. ld-linux.so) was not found;
  • the program is a foreign binary but qemu was not specified;
  • qemu does not work correctly (if specified);
  • the loader was not found or doesn’t work.
    fatal error: see proot --help.
    proot error: can’t chmod ‘/tmp/proot-30864-ifnVxc’: No such file or directory

I also made sure SELinux was disabled:

[~]# sestatus | grep -i mode
[~]# sestatus
SELinux status: disabled

Also checked that ld-linux.so was installed
Package glibc-2.12-1.209.el6_9.2.i686 already installed and latest version


#6

did you extract the .tar.xz using tar or using some other random extraction utility?


#7

619 2017-12-04 19:48:47 tar xf fx.tar.xz


#8

also:
Package xz-4.999.9-0.5.beta.20091007git.el6.x86_64 already installed and latest version

This is on
[~]# cat /etc/redhat-release
CentOS release 6.9 (Final)


#9

so I’ve bypassed using proot, but now I’m getting:

exec /opt/cfx-server/FXServer +set citizen_dir /opt/cfx-server/citizen/
-bash: /opt/cfx-server/FXServer: /lib/ld-musl-x86_64.so.1: bad ELF interpreter: No such file or directory
-bash: /opt/cfx-server/FXServer: Success

help?


#10

so you clearly did not bypass using proot


#11

yeah… that’s in no way helpful at all


#12

neither is the information you provided for your issue, it’s probably your linux kernel denying something that should work perfectly fine according to the ABI.

are you using some kind of creepy patchset like grsec?


#13

What information is needed? If the kernel was denying nproc calls, wouldn’t those appear in either dmesg or /var/log/messages? Neither show anything. No, I’m not using grsec, and SELinux is disabled.


#14

The problem seems to be from the fact that proot tries to create and execute files from inside /tmp, so if you have it mounted as noexec it will give you the Permission denied error.
To fix it, mount /tmp with exec option:

mount -o remount,exec /tmp

#15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.