ESX_Society Console Error


#1

Hello Guys, i have this Problem: `
Loaded System.Threading.Tasks.Extensions, Version=4.1.1.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51 into ScriptDomain_1218967590
Loaded System.Buffers, Version=4.0.2.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51 into ScriptDomain_1218967590
Error running system event handling function for resource esx_society: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: server/main.lua:39: attempt to index a nil value (field ‘?’)
stack traceback:
server/main.lua:39: in upvalue 'handler’
citizen:/scripting/lua/scheduler.lua:163: in function
stack traceback:
[C]: in function 'error’
citizen:/scripting/lua/scheduler.lua:41: in field 'CreateThreadNow’
citizen:/scripting/lua/scheduler.lua:162: in function

Current MelloTrainer Version: 0.5.5
Latest MelloTrainer Version: 0.5.5
MelloTrainer is up to date!
MELLOTRAINER: mtsaves folder found!
hitch warning: frame time of 1218 milliseconds `

a ESX_Society Error. I started the Server first 1 hour ago so all works and now i restarted the server and the Error commings i already installed my server 4 times and won’t work please help

HOW TO FIX:
Reinstall your Server first!
Then it is important that you install ESX normally so synonymous with ESSENTIALSMODE. If you did, start the server and see if everything works. Then turn off the server again and now you insert the POLICE JOB. If you then insert the SQL file of the POLICE JOB you will get an error ESX Addon account was not found. Then you install ADDON INVENTORY / ADDON ACCOUNT and import the SQL file from the ADDON / INVENTORY / ADDON ACCOUNT now you import the POLIZEI JOB SQL file and then you install normally ESX Society. Then start the server and it works. So before I installed ESX STATUS I tried it and made a backup


#2

Esx society has bugs very probably because you use a job script coded with the ass and something is missing in your DB. Already happened. Uninstall all unofficial jobs both from db and files.


#3

I only have the ESX Police Job Ambulance Job, Taxi Job, Mecano Job and not more only a Jobs Pack with 5 extra jobs but it should be work on other servers


#4

I have the same thing and i’m sure it was from the mecano job it said known bugs with props not working


#5

Which jobs from the pack ?


#6

ESX Jobs (But i don’t have the error anymore i fixed it easy)


#7

What did you do to fix it?


#8

Could you tell us how you fixed it?


#9

we have the same problems with both of our servers ! how do we fix it?


#10

Can you tell us how you fixed it please?


#11

REINSTALL YOUR SERVER AND DATABASE
Then it is important that you install ESX normally so synonymous with ESSENTIALSMODE. If you did, start the server and see if everything works. Then turn off the server again and now you insert the POLICE JOB. If you then insert the SQL file of the POLICE JOB you will get an error ESX Addon account was not found. Then you install ADDON INVENTORY / ADDON ACCOUNT and import the SQL file from the ADDON / INVENTORY / ADDON ACCOUNT now you import the POLIZEI JOB SQL file and then you install normally ESX Society. Then start the server and it works. So before I installed ESX STATUS I tried it and made a backup


#12

so is the problem esx_status then


#13

I had this exact error. The solve for me was that the esx_jobs_en sql file doesnt work, you have to use the french original one or its not going to work.


#14

Yes shure that is the problem!


#15

Okay, thank you! <3 #20Charachters


#16

What difference is there between esx_jobs_en.sql and esx_jobs.sql for it not to work? Is the script looking for specific names in the database instead of table indexes?


#17

The problem for me was that I had the grades of jobs that I had deleted in my sql, I deleted them and it started to work.