[ESX_Shops] Problem, please help


So basically esx_shops worked for me at start and when i added some other esx resources suddenly when i press E in shop, nothing pops out and also i am not getting any errors in console and everything else working fine.

Server.cfg resources for ESX.

start mysql-async
start essentialmode
start esplugin_mysql
start es_admin2
start es_extended
start cron
#start async
start esx_datastore

start esx_addonaccount
start esx_addoninventory
start esx_identity
start esx_joblisting
start esx_jobs
start esx_shops
start esx_policejob
start esx_society
start esx_billing
start esx_menu_default
start esx_menu_dialog
start esx_menu_list
start pNotify
start dmvschool
start esx_status
start esx_basicneeds
start new_banking
start esx_holdup
start esx_phone

Maybe its because of esx_addoninventory, i tried also to start only few basic resources but its same. I think that i need to do something in SQL Heidi because probabbly i imported esx_addoninventory but i need to do something. Please help ,i’ll appreciate any information.


Check in your database to make sure everything you have in your shops table, is in your items table. And check that everything you intend on selling in your shops, is also in your items table. More than likely you have an item in your shops table that doesn’t exist in your items table.


Everything is working fine. Exactly i didn’t put stuff from shop table in items, i am feeling stupid right now mate, thank you alot i appreciate help !!


no worries man it happens. glad its working


Bro how can i put stuff from shops to items


Whatever items you have in shops table of the database, you need to have them in your items table also


How do i add them into items


You need to connect your Heidi SQL program with your mysql database, open Heidi and then go in shops and mark to view data on your heidi. Then you will have all items in your shop. And if you wanna add any item go in items, look how it is called and put it in shops table.