[ESX] ls-radio | Radio for everyone with TokoVOIP

I uploading my script for radio.
It enables us to use the radio joining/switching/exiting from 1MHz to 100 MHz (1-10MHz its reserved for police, ambulance and fire) for officers and civilian. We can set in the config.lua what channels are to be restricted(default 1 - 10), and what should be opened to anyone who has the item radio



For working you must add item radio in your database.
For enable /radio command change in config.lua from

Config.enableCmd = false
Config.enableCmd = true


Leaving the current radio channel, click here:

Link Github

GL&HF :slight_smile:


nice job now time for one to work with discord since a lot uses discord now days ts is outdated.


This is a really neat concept, but discord doesn’t support server-set volume for users or positional audio.

Ah! It feels great. Could you upload a demo video?:grinning:

1 Like

Does it need server-set volume though?

only for radio not

i keep getting a black screen after installing it @alcapone_dev

This is banger, easy to setup and works well. Thanks.

1 Like

you have tokovoip configured?

this is it correct?

yes, show what black screen u have.
u joining on correct teamspeak channel?

yup ill show you rn

You have installed plugin in teamspeak? I see “Initializing”

yes, idk whats going on…

check if you have turned on plugin in the teamspeak options and if you have the latest version of teamspeak (3.3.0). U can try reinstall teamspeak and Toko plugin (https://github.com/Itokoyamato/TokoVOIP_TS3/releases/download/v1.2.4-v1.3.2/tokovoip_1_2_4.ts3_plugin)

This is not the fault of the script but you have something wrong with TeamSpeak

just updated both and im getting this error

try doing fresh install on both, u should be fine after.

“Api Version is not compatible” You must update TeamSpeak client to version 3.3.0
u can check your teamspeak ver here:


and update is here: