Essentialmode for mysql


#1

hi guys
i want essentialmode that works on mysql please
i did search everywhere i dident find the new verion works only on coushDB
all i found dont work on mysql
can someone help me please


#2

Lol… You haven’t even bothered to look, have you?

From the original post:


#3

i did every thing dosent work for me i have installed esplugin and did every thing
the script only works on coushdb not on Mysql


#4

What?!?

The “esplugin_MySQL” is literally built for MySQL and not CouchDB. If you can’t figure out how to use it, even after following the instructions, then there’s nothing we can do. They pretty much take you through how to set it up step by step. If you have an issue with the plugin not working (e.g. you get an error message) then, you’ll have to ask in the original topic.

If you’re having an issue with a specific step, or want clarification. Tell us which step and we can help you better, until then there’s nothing we can do to help.


#11

I followed the steps myself and still cannot get it work work. You do not clarify in your instructions which actual files to edit to make it work. You just say server configuration. Is it the server.cfg in the root of fx or is it essential config? or where for both the async line that talks about where to put the database information and the customdata line? Those instructions is not clear.


#12

Not my instructions but, which are you referring to specifically? You don’t need to mess with any files (there’s no mention of files in the instructions except the SQL file).

Considering pretty much everyone refers to the cfg file as being the “server config” I thought you’d know that it is, in fact referring to the “server.cfg” file.

What? I’m pretty sure you’re referring to the “server.cfg” file again.


#13

Maybe this helps @Voorhees_Jason ?


#14

Here’s my issue. When I change the req’d file to make custom data enabled by removing the two dashes, when I clear the cache, and restart the server I get the following error:

error parsing script server.lua in resource esplugin_mysql: server.lua: 2: syntax error near Custom Data.
Failed to load script server.lua

Line 2 says the following:

es_enable CustomData 1

Please help, this is the last error, and then my server is dos error free.


#15

make sure es_enableCustomData is one word (no spaces), so like this:

es_enableCustomData 1

#16

That’s the issue. When I removed the "–"from the front of the “es” it was written with a space between enable and custom. I haven’t dealt with syntax issues in 20 years, and I hate them as much today as I did back then. lol
However, it has one thing over 5M, when something doesn’t “load”, all I get is a frown face…Syntax errors at least tell you where the issue is. :slight_smile:


#17

new problem this one is a variant from above. whenever want to enable custom data I am getting a syntax error on line 2…

set es_enableCustomData 1

Please help.