Essential Mode issue what do i do


#1


#2

Same issue happened to me, It magically went away somehow. What resources are you using, and what do you do to get this messages?


#3

any time i go to use anything involving essentialmode


#4

@Matt4499 do you know how to fix this issue


#5

Like what? You’re doing something specific to cause an error. In my experience, doing a chat command with the wrong ID throws very similar errors to what you’re seeing.


#6

for example if i do /announce it gives me this error
or anything else to do with EM


#7

There should be an error on the server console. What does it say?


#8

Error running call reference function for resource essentialmode: citizen:/scripting/lua/scheduler.lua:351: server/main.lua:218: attempt to index a nil value (field ‘?’)
stack traceback:
server/main.lua:218: in upvalue ‘ref’
citizen:/scripting/lua/scheduler.lua:337: in function citizen:/scripting/lua/scheduler.lua:336
[C]: in function ‘xpcall’
citizen:/scripting/lua/scheduler.lua:336: in function citizen:/scripting/lua/scheduler.lua:335
stack traceback:
[C]: in function ‘error’
citizen:/scripting/lua/scheduler.lua:351: in function citizen:/scripting/lua/scheduler.lua:322


#9

@SaltyGrandpa that is the error i get in the console


#10

Please ask for support in the original resource topic only. Do not start new topics about issues/questions regarding specific resources.

This way the forums won’t get cluttered with a ton of topics for small issues, which may or may not have already been solved or answered in the original topic.

That way everyone can find their answers and ask their questions in one place, so the original creators get notified of the question and everyone knows where to look for answers and where to support others with a specific resource.

:mascot: