Error with ESX_Menu_Default


#1

Anyone having an issue with the ESX_Menu_Default giving a uncaught type error: cannot read property of ‘scrollintoview’ of undefined when opening some menus?


#2

Yes, having the same issue. Preventing the Weapon shops, cop job and other menus from displaying.


#3

Same issue here. Someone figured out how to fix it?

nui://esx_menu_default/html/js/app.js:64, Uncaught TypeError: Cannot read property 'scrollIntoView' of undefined.


#4

How to fix it?

nui://esx_menu_default/html/js/app.js:136, Uncaught ReferenceError: SendMessage is not defined


#5

Has there been a resolution to this? I have just tried to add weapon stores and Im getting this error in the console too
thank you


#6

Afaik there is no solution yet. At least I haven’t been able to find one. There’s an issue open on Github as well.


#7

Nothing on this yet?


#8

Same here. Also getting ‘cannot read property namespace’ error too. This still the same for everyone else at the moment?


#9

this is the line of code that doesnt work… looking at it right now.

$(’#menu_’ + namespace + ‘_’ + name).find(’.menu-item.selected’)[0].scrollIntoView();


#10

the new esx_menu_default update should fix this if not pls let me know


#11

Error is still there.

nui://esx_menu_default/html/js/app.js:64, Uncaught TypeError: Cannot read property 'scrollIntoView' of undefined.

It goes away when I have something in inventory (including money) but I know the problem will show up other places.


#12

hi i have gotten a similuar error when i join in to my server i get this error

Sending heartbeat to live-internal.fivem.net:30110
Connecting: Rev******
Sending heartbeat to live-internal.fivem.net:30110
nil ~= 1
Sending player (1) ELS data
[ERROR] [MySQL] An error happens on MySQL for query “INSERT INTO user_inventory
(identifier, item, count) VALUES (@identifier, @item, @count) {@identifier=steam
:11000010*******;@count=0;@item=intestin}”: Couldn’t connect to server
Sending heartbeat to live-internal.fivem.net:30110
[SAVED] Rev*******

now i load in fine but when i try use any menu like shops, inventory, garage, job, any of them they kind freeze in place and you cant press or close them in debug i get this

nui://esx_menu_default/html/js/app.js:152, Uncaught ReferenceError: SendMessage is not defined

server CMD load: https://pastebin.com/MVn1qwdj

Please Help!!!
Will also update incase i find a fix
Thank you

UPDATE
i managed to fix my issuses by rebuilding my database Items table and shops table
fully delete the shops table and then get the sql and reload it in then in items go through it and delete Bread,Water.Hamburger,CokaCala,Milk, Ect… anything to do with ESX_shops basically then after uv removed that Reload the basicneeds sql into your database and bang done should be fixed may not work for everyone it seems to happen when items are duplicated in the database this is also the fix for Menus opening but not being able to navigate or push buttons if this doesnt work try reinstalling all 3 ESX_menus hope this helps


#13

go back to the previous version and it will work again :wink:


#14

Since not everyone has access to previous version, could you share it here? Or at least the coded needed to run this normally?


#15

Same here … 20…


#16

For the people that doesn’t know it’s fixed: Download the latest es_extended. Been working for a couple of days now.


#17

But es_extended isn’t esx_menu_default, which has been causing issues above? This last mentioned hasn’t been updated since March this year.


#18

I have the same issue as above and cannot find a solution either.

Have tired everything mentioned here also.


#19

Please do not create new topics for support/questions related to existing resources.

Only ask questions or request support in the original resource topic, or on whatever site/page you got the resource from (for example: create an issue on the GitHub page of the resource that you downloaded).

That way the original resource creator will get a notification and be able to help properly. This also helps to reduce duplicate topics of the same issue, because everything will be inside the original topic, allowing everyone to see all issues and solutions in one place.

Thanks for keeping the forums tidy.
:mascot: