Davedumas0's small script collection


#1

here is a collection of the scripts that im working on





the gui and menu scripts are originally from here


all credit for menu goes to frazzle


#2

please stop using that “keys” table.

seriously.


#3

why is there something wrong with it ?


#4

So many things wrong with it


#5

if its your resource then for sure ill just use the numbers


#6

Use my gui. Or even @Warxander version of it.


#7

Every time i try to load the script, it fails to load resource. When I just use bunkers.lua by itself, it works. It only shows to the bunkers but, without the menu and stuff then it is useless. When I try to load in the menu resource or anything else in that directory it fails to load resource.

I updated FX, I tried to remove all my other scripts and make this standalone and still same error.

Any idea of why?


#8

ill fix it after work today(in a few hrs)


#9

Oh ok cool. Do you know what causes it?


#10

i had all my stuff in separate resources on my pc did not do that with the git fixing it now


#11

ok, cool. Let me know when I can re download. Do you know how to get the money part of this stuff to work with vrp?

You are the best

Thanks for the great work on this script.


#12

should be working now


#13

It loaded up with no errors :slight_smile:
The only thing i see on the map is the bunkers but, when I go near and around and on top of one nothing happens or no markers. How does this work?


#14

oops
i only have one bunker entrance working atm


#15

ill delete the others for now


#16

just comment out all but one like this

  --{n = 1, x=-3058.714, y=3329.19, z=12.5844},
  --{n = 2, x=24.43542, y=2959.705, z=58.35517},
  --{n = 3, x=481.0465, y=2995.135, z=43.96672},
  --{n = 4, x=848.6175, y=2996.567, z=45.81612},
  --{n = 5, x=2126.785, y=3335.04, z=48.21422},
  --{n = 6, x=2493.654, y=3140.399, z=51.28789},
  --{n = 7, x=1823.961, y=4708.14, z=42.4991},
  --{n = 8, x=-783.0755, y=5934.686, z=24.31475},
  {n = 9, x=-3180.466, y=1374.192, z=19.9597},
  --{n = 10, x=-783.0755, y=5934.686, z=24.31475},
  --{n = 11, x=1570.372, y=2254.549, z=78.89397},
 -- {n = 12, x=-391.3216, y=4363.728, z=58.65862}
}

p.s. im on discord you can pm me there if you wish


#17

yea. I found it and the yellow blip but when walking to the blip it does nothing. Am I suppose to do something?


#18

which discord are you on?


#19

can you also add a small description of what your scripts do?


#20

What is the yellow marker inside the Bunker for? And furthermore if someone drives one of the vehicles inside of the Bunker he can only see that himself. Everyone else in the Bunker sees him falling through the floor. I tried just to remove the vehicle spawning. Worked fine for the hauler2 but the caddy3 doesn’t seem to appear in the script…