cURL Error Code 7 (Firewall is off, no anti-virus, ports are forwarded and have been for weeks)

To receive support, please fill out the following template, and remove this top text.

GTA V version? Latest
Up to date? Yes
Legit or Pirate copy? Legit
Steam/CD/Social Club? Steam
Windows version? Yes
Did you try to delete caches.xml and try again? No
Error screenshot (if any)
System specifications N/A
What did you do to get this issue? Today
What server did you get this issue on? My Server
CitizenFX.log file N/A
.dmp files/report IDs N/A

If an issue with starting: N/A
GTA V folder screenshot
GTA V/update/x64/dlcpacks screenshot
Filepath to FiveM folder
FiveM client folder screenshot
Did you try to disable/uninstall your Anti-virus?

Also add what you already tried so far. I am running my Fivem server on a VPS. It was all working fine until today… I restarted the server and now it just constantly has a cURL error code 7 when players try to connect… I have no idea how to fix this. I’ve restarted as well as rebooted the VPS several times to no avail… I really need to get this server up as soon as I can… Thank you.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the FiveM community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

Does anyone have any ideas?..

I need this fix…

Have you updated to the latest artifacts?

Yes I have to no avail. I just constantly get the error… It started to happen after we restarted our server and then bam now it’s been constantly happening… However I downloaded a Fivem server creator to test and that server ran fine. I’m wondering if our FXServer artifacts had gotten corrupted or something?

Backup your resources & cfg files, Then completely reinstall all the server files!

Did this, I used the FXServer creator and I can get on that server fine, then I take the latest artifacts replacing the ones it comes with, put my resources and configurations back. cURL error still…

Tried a different port?

Figured it out. Oddly enough it was a server.cfg error… No idea really where the error was… I’m assuming the order of starting some things up and where setting server values were messed it up… Very odd to say the least… Nonetheless for future reference, try a default server.cfg, if that works, then you need to figure out where the problem is in your server.cfg. Will take some troubleshooting, but you’ll figure it out eventually with enough trial and error like I did. I just wish %curl command in Fivem’s discord actually listed all possible problems… They don’t know what they’re talking about…