Crash "Failed to call inflate() for streaming file......."


#1

any idea? just start happend since 2h :confused:

When play 10-20seconds it crash …


#2

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the FiveM community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:


#3

hi. i have exactly the same probleme (exect ydr name off course)

FiveM Error
[Main Instruction]
FiveM has encountered an error
[Content]
Failed to call inflate() for streaming file compcache:/Props/v_40_hospseating2.ydr.
Read bytes: ef 68 f3 06 be 99 83 75
RSC version: 165
RSC page flags: virt a0020000/phys 50000000
Resource name: Props
Reference hash: f367f386f585a94f45c0e1c957dbb60c54385cc1
Status: StatusFetched
Downloaded now: No
RSC header: 3d 06 31 72
Resources for hash:
-> Props/lr_supermod_carlift2.ydr
-> Props/lr_supermod_cheetah.ydr
-> Props/lr_supermod_peyote.ydr
-> Props/v_40_debris1.ydr
-> Props/v_40_debris2.ydr
-> Props/v_40_debris3.ydr
-> Props/v_40_debris4.ydr
-> Props/v_40_debris5.ydr
-> Props/v_40_debris6.ydr
-> Props/v_40_debris7.ydr
-> Props/v_40_debris8.ydr
-> Props/v_40_exitpillar2.ydr
-> Props/v_40_hospital1shad.ydr
-> Props/v_40_hospital1shadb.ydr
-> Props/v_40_hospital2shad.ydr
-> Props/v_40_hospital4shad.ydr
-> Props/v_40_hospitaldoors_fixed.ydr
-> Props/v_40_hospitalpipes.ydr
-> Props/v_40_hospseating005.ydr
-> Props/v_40_hospseating006.ydr
-> Props/v_40_hospseating007.ydr
-> Props/v_40_hospseating008.ydr
-> Props/v_40_hospseating1.ydr
-> Props/v_40_hospseating2.ydr
-> Props/v_40_hospseating3.ydr
-> Props/v_40_hospseating4.ydr
-> Props/v_40_sidedr.ydr
-> Props/v_40_sign020.ydr
-> Props/v_40_wallbit.ydr
-> Props/v_40_wood.ydr
-> Props/v_40overlay1.ydr
-> Props/v_40overlay1b.ydr
-> Props/v_40overlay2.ydr
-> Props/v_40overlay3.ydr
-> Props/v_40overlayrubble.ydr
-> Props/v_med_fabricchair1.ydr
-> Props/v_med_hospseating3.ydr
-> Props/v_med_hospseating4.ydr
-> Props/v_med_hosptable.ydr
-> Props/v_med_hosptableglass.ydr
-> Props/v_med_mattress.ydr
-> Props/v_med_whickchair2.ydr
-> Props/v_med_whickchair2bit.ydr
-> Props/v_med_whickerchair1.ydr

Please try restarting the game, or, if this occurs across servers, verifying your game files.

If you require immediate support, please visit FiveM.net and mention the details in this window.

[^] Hide details [Close]

[Expanded Information]
Crash signature: gta-streaming-five.dll+573C2
Report ID: … [uploading?] (use Ctrl+C to copy)


#4

Having the same issue on my end with something different pertaining to a ydr


#5

Same issue here too.


#6


#7

I’ve been running into this issue on my server a lot starting yesterday. I think it has something to do with a FiveM update since the resource it keeps referencing hasn’t been changed in months.

I keep an old version of my priv folder, and when I switched to it, the crash stopped happening.

UPDATE: Okay no, that didn’t work. It only took more time until it crashed.

UPDATE: I stopped the resource and the crash stopped. It kind of sucks not having that resource anymore but it was a pretty big addon map so maybe it’s a size thing??? My point is it’s not totally random.

  • M

image


#8

Have you tried to delete cache files?
Sometimes it works…


#9

I tried that a few times. Both client and server. It seems to delay the crash but not by much.


#10

Now it’s doing it for a different resource. Is anyone else still having this issue?

image


#11

Yup I’m still having this issue with my ydrs that worked perfectly fine till the recent updates… Unsure what was changed,


#12

Have you tried deleting everything in your FiveM priv folder? I think that solved the issue for me so far but I have to test it a few more times to be sure. Of course you’ll have to re-stream all the assets.

Since the update I noticed the naming convention of the files in there has been changed, so I have to agree with you.

  • M

Update: Nope. It didn’t work. I still got the crash after about half an hour.


#13

Provide a repro resource, perhaps. :open_mouth:


#14

I’m sorry, I don’t think I know what you mean. Did you want to see the resource that the error message was talking about?

If I press F8 to open the console, I see it re-downloading some assets I already have in my cache. Does that mean anything?


#15

f8 error


#16

@mattzero the element wants somebody to provide a resource that can reproduce this error.


#17

The resource is a little big. We’re talking 200+MB here. (All the files are <16MB)

Again, the resource hasn’t changed in months so it’s not like I can revert to an old version.

I’ll upload it, but I’m hoping someone else can provide a smaller one.

https://drive.google.com/file/d/1enimdxAcX12TeV2rlaBhzaW3eweSU_nY/view?usp=sharing

To reproduce: Visit the new map east of the main map at least once (so it’ll download all the map files). Then quit FiveM and launch it again. After max 30 minutes of roaming the main map and jumping between interiors, it throws the crash. If you want to speed it up, try equipping a custom weapon skin. That seems to make it crash sooner.

Hope this helps.


#18

I doubt that’s actually the relevant resource - most people seem to have two ‘resources for hash’ showing - this one crashing is most likely a random side effect. :confused:

We also can’t find what weapon skins people are using to trigger this (with multiple equivalent files with different names), so this is hard to reproduce, and in addition to that nobody posted log files either.


#19

When I stopped that addon map resource, the crash completely stopped happening. I can’t repro without it.

Here’s the custom heavypistol I use: https://drive.google.com/file/d/1QuFlJsMt4FoY02yzAJvOs6eALDmGlG6Q/view?usp=sharing
Or if you want every weapon skin I have. Like you said, it could be a side effect. Maybe this is the culprit:
https://drive.google.com/file/d/1yofBZHaHUczutxILbg1x8naiPWw3n6Vm/view?usp=sharing
Don’t put them both together, they have conflicting files.

CitizenFX.log (150.5 KB)

^ I entered the Doomsday submarine, used a ‘Get All Weapons’ cheat and then quickly cycled between a bunch of weapons (some with custom models, most of them already downloaded in my cache). My character started holding nothing for a few seconds and the game crashed. If I don’t use the weapons, the same crash occurs at random after about 30 minutes.

I hope this helps.

  • M

#20
[   1578964] ResourceCache::AddEntry: Saved cache:v1:c360ea343d3db7492243ef296bfc77e38af5259e to the index cache.
[   1578980] ResourceCacheDevice::OpenInternal: compcache_nb:/fujimi_addon/_fujimi_kaido15.ydr didn't parse as an RSC. Refetching?
[   1578980] ResourceCacheDevice::EnsureFetched downloading _fujimi_kaido15.ydr (hash c360ea343d3db7492243ef296bfc77e38af5259e) from https://127.0.0.1:30120/files/fujimi_addon/_fujimi_kaido15.ydr
[   1579120] ResourceCacheDevice: downloaded _fujimi_kaido15.ydr in 132 msec (size 3539222)
[   1579136] ResourceCache::AddEntry: Saved cache:v1:c360ea343d3db7492243ef296bfc77e38af5259e to the index cache.
[   1579136] ResourceCacheDevice::OpenInternal: compcache:/fujimi_addon/_fujimi_kaido15.ydr didn't parse as an RSC. Refetching?
[   1579151] ResourceCacheDevice::EnsureFetched downloading _fujimi_kaido15.ydr (hash c360ea343d3db7492243ef296bfc77e38af5259e) from https://127.0.0.1:30120/files/fujimi_addon/_fujimi_kaido15.ydr
[   1579261] ResourceCacheDevice: downloaded _fujimi_kaido15.ydr in 114 msec (size 3539222)

Interesting - it seems you’ve got 2 different variants of this issue. Now, the real question is - why does this file end up corrupting itself on download?