CMD Error?



Info :
GTA V version?
Latest version
Up to date?
Yes !
Legit or Pirate copy?
Legit Version
Steam/CD/Social Club? ??
Socialclub version
Windows version?
Win10 Pro
Did you try to delete caches.xml and try again?
Yes , didnt solved to problem
Error screenshot (if any)
What did you do to get this issue?
Configure the server , Setup Essentialmode , Setup the Database ( Xampp + Mysql + PHPMyadmin) , Connected to Database.
What server did you get this issue on?
My own server for personal use , not public.

Server CMD :

In-game screen :

Resource map :


Hello All! ,

I have an error problem in my server cmd , this error pops up at the moment i join the server.
My guess is that there is a problem with sending information to the Database .
This error popped up after i installed Essentialmode to my server .

Essentialmode is Working on my Database it created an entry for my character with steamID , start cash , Level etc.
so it does send info to the database .
but i cant figure out why the error pops up at CMD server .
The server shows me this after i joined the server :

Connecting: Kevichill
Sending heartbeat to
Loaded System.Threading.Tasks.Extensions, Version=, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51 into ScriptDomain_1915289698
Loaded System.Buffers, Version=, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51 into ScriptDomain_1915289698
Access denied for command add_principal.
^ ^ ^ ^ ^ ^ This error isnt going away ,
and i dont know what to do about it at the moment .
when i am in the server , the commands of essentialmode works , i can make myself admin , i can kick myself etc. that all works , but i dont know why that error popps up , and i want it to go away ofcourse ;p

my guess is there is something that isnt connecting to the DB on a right way .
Can someone help me out a little ,

for extra info :
I didnt use any other Mods at the moment on the server just Essentialmode ,
No CouchDB !
Yes Mysql-async
Yes Mysql server + DB

I appreciate the help !

Im sorry for the bad english .

Greets Kevin .


did you add yourself as an admin? if not then it makes sense that you are getting that error and would need to add yourself to the group.


In your server.cfg file, at this section:

make sure you use your steam (hex) identifier. NOT the one you used above.
It’d look something like this:

add_principal identifier.steam:110000105959047 group.admin

To get your steam hex identifier go to and enter your steam name in the search bar in the top right of that site. Once entered copy this value of course without the (Hex) part:


I did , still having that error .


Hey thanks for pointing that one out ! i did used the wrong steam ID , thanks !
After i changed it i noticed i still got the error ,
after reading and reading and reading some more i found out in a post
that essentialmode5 is blocking this command ,

see post : FXServer is blocking a command?

VespuraRegular tells them :

Alright I think I know what the issue is. Because it’s being executed by a resource - it’s also executed by the system.console group but FIRST it’s executed as your resource - you need to make sure that you allow that resource to execute that command.
So in your permissions section in your server.cfg file make sure to put something like this:
add_ace resource. command.add_principal allow
Edit: I’m not 100% sure if this will work, so correct me if I’m wrong

So i added to server.cfg :

nested configs!

#exec server_internal.cfg
add_ace resource.essentialmode command.add_principal allow <—

Now the error is gone ! :slight_smile:

Thanks for the help !


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.