Can't run FXServer


#1

Hello everyone.

Suddenly when I try to launch my server with a batch file I get this error
"run.cmd not recognized as internal or external command"

However, it worked like 10 minutes before.
My .bat files deleted itself and whenever I try to run it again, I have this message prompted.
I didn’t delete or modify any files.

What can I do ?

Thanks in advance.


#2

Hello

I have a second error when I type in cmd to run the server
I get “D:\FXServer\FXServer” not recognized…
65845


#3

You must use quotes if the path includes spaces! "D:\FXServer\run.cmd" +exec server.cfg, or just ../run.cmd +exec server.cfg


#4

It still doesn’t work, and I didn’t use quotes when it was working.

Thanks anyway


#5

Nothing is really wrong, you’re just not giving the right path


#6

wait shouldnt you be running your path as D:\FXServer\server-data\run.cmd +exec server.cfg ?

as it is you put yourself into the D:\FXServer\server-data directory then tried running D:\FXServer\run.cmd which is not the directory you are in so it should be what i stated above.


#7

No it doesn’t work and the path is the right one, it was the one I gave and it was working fine.
Even when I write “D:\FXServer\server-data\run.cmd +exec server.cfg” it doesn’t work


#8

well all i know is in that screenshot you were trying to start it in a directory that the file dont exist in… either way you seem to be running it from the incorrect path, show me another screenshot with the way i told you to do it.

Also post screenshots of your fx folders.


#9

actually… i think its because you are cd’ing to the server-data directory so goto FXServer then run the command not FXServer/server-data only thing i am serton of is you are trying to run it out of the wrong directory.

Also try doing run.cmd +exec server.cfg without the directory path infront of it because if you are in /FXServer/ then you dont need to put the path infront of it so do cd /FXServer then do run.cmd +exec server.cfg


#10


#11

Hes using Windows :wink:


#12

I tried a lot of things65687


#13

Change the directory into the server-data folder then, do ../run.cmd +exec server.cfg


#14

The same message as above is displayed


#15

Have you at some point edited the run.cmd? because its always trying to run “D:\FXServer\\FXServer” which is never going to work.


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.