Can't join my own server by localhost


#1

Basically, by changing the IP in my server settings file to my IPv4, I can join via the “Direct Connect” option but not the “Localhost” option. But, before changing the parameter, I was able to join through “Localhost”, but other people could not join my server because the IP was set to 0.0.0.0:30120.

GTA V version? - Latest on Steam
Up to date? - Yes
Legit or Pirate copy? - Legit
Steam/CD/Social Club? - Steam
Windows version? - Windows 10 Home 64-bit
Did you try to delete caches.xml and try again? - Couldn’t find such file in my server folder
Error screenshot (if any) - Provided below
System specifications - Intel Core i5-4460 3.2 GHz | XFX Radeon RX 480 8GB GDDR5
What did you do to get this issue? - When I tried to change the IP address of my server so that my friends can join it
What server did you get this issue on? - My personal server
CitizenFX.log file - Provided below
.dmp files/report IDs - CURL Error Code 7

If an issue with starting:
GTA V folder screenshot - Provided below
GTA V/update/x64/dlcpacks screenshot - Provided below
Filepath to FiveM folder

FiveM client folder screenshot - Provided below
Did you try to disable/uninstall your Anti-virus? - Yes

Also, add what you already tried so far.
Restarted my computer
Restarted my router
Port Forwarding 30120
Checking Netstat (30120 doesn’t seem to be listening to anything)
Allowed anything FiveM related through Firewall


#2

Changing or changed IPV4 ip adress is normall especially you have an router assigning ip adresses to clients.

Do you know that your ‘localhost’ js you loopback same as 127.0.0.1. Windows have them in host file. Where in not especting ALL to bee the issue in.

Becouse i waited 2 days for someone else to respond!

**First of all **
Your FX Server had .cfg the default one i geuss, on the top you see an 0.0.0.0:XXXX addres **You will not need to change it in anything keep it at it! Only the XXXX port value you change!

This is for advanced settings!

Make that sure, in recommand an default server.cfg to solve it!

This XXXX port value you port forward TCP/UCP To the IPV4 adress in your router.

Also i think your issue is really easy, but nobody reaponded so i want to know now haha!!

Your FIREWALL, disable it completely and test! It it was the issue make rules in your Windows : Advanced Firewall Settings

Goodluck! And i espect an answer :wink:

Greets,
NoOneKnows


#3

Hello, TheUnknown

First of all, I’d like to thank you for your concern for my problem. I usually do not have this luck on the forums, however, I was lucky this time!
Moving on to the subject itself, by disabling the Windows Firewall and changing that IP setting to default, I was able to log in to the server via “Localhost” but not others. Looking for the full list of servers or by entering the IP of my server in the “Direct Connect” option, my friend could not find my server.
I am looking forward to able to solve this problem! Once again, thank you for your time and effort! :smiley:


#4

Hey!

Well oke, thanks for trying atleast! So for you its working on direct IP Correctly ? do you use your external ip adress or internal.

Try this, if its here its there.(Server Recommanded by FiveM Official) im not advertising my own server on purpuse.

This server is online, confirm it for your self by visiting the link and see details
Server - List Check
Notice also that this is the exact same list if you run FiveM

What i want you to do :

https://www.yougetsignal.com/tools/open-ports/

EDIT ONLY YOUR PORT TO 30120 or what ever you use and run the server ofcourse. If you have virtual porting its telling closed port insteat of open. And port the one you have forwarded in your router, to the computer/server thats RUNS the FiveM Server.


https://servers.fivem.net/#/servers/detail/EXT-IP:FORWARDED-PORT


And port the one you have forwarded in your router.

If the port is cosed as result you there you see FireWall is an issue. If its open, and the understanding is not rusulting an view like the first link. I will be confused :wink:

To check for your server :
https://servers.fivem.net/#/servers/detail/EXT-IP:FORWARDED-PORT

Sorry for my late reaction! But im not always so active on the forums! Hope that you will tell me your output!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.