Batch File issues/server key issue


#1

Server not starting with batch file
Running the sever off my personal computer starts fine. Batch file looks like this

cd /d D:\FiveMServer\cfx-server-data-master
D:\FiveMServer\run.cmd +exec server.cfg

The server config is in the cfx-server-data-master folder. This runs no issues off my personal PC.
Trying to run this off my private server box (only has a C: Drive ) it will not start. batch file looks like this

cd /c C:\FiveMServer\cfx-server-data-master
C:\FiveMServer\run.cmd + exec server.cfg

Gives me this error
image

I have updated the license key so I am not sure why I am getting this issue. I have even tried putting the server.cfg in the root FiveMServer folder and it will start but my resources wont load…

Any help would be greatly appreciated!


#2

Need more information of the server console output.

  1. Does it start all the resources and then complain about the server key? Or before that?
  2. Did you by mistake save your server.cfg as a txt file?
  3. Why are you doing cd /c??? There is no such parameter. cd /d is for changing drives. All you need is cd

#3
  1. It stops right away with that issues not loading any resources. (update after fixing #3 it loads resource then stops.)
  2. It is a server.cg (not text)
  3. Fixed that error on my end.

After that is loads but stops at the server key. I have tried both ‘key’ “key” and key (with out " or ’ )


#4

Are you sure you entered the correct IP for your key? You need to create a new key with the external IP of your server


#5

Yes. I tried again with a fresh key and its still giving me the server key issue…


#6

It’s not an authentication error otherwise, it would say it was an authentication error. The server can’t find the key in the file you’re providing.

What’s your server directory look like (with the CMD file in it)?
What’s your server-data-master look like?
What’s your config look like (censor sensitive data if needed)?
What’s console look like?

Answer those questions (pictures are worth a thousand words here) and we can better help you :slight_smile:


#7

First off I appreciate the help y’all

Server directory

Server-data-master

config


console with error


#8

I don’t know if it makes a difference, but put your sv_licenseKey at the end of your file. Could be that it adds the endpoints first and then sets the config variables


#9

I tried that again and it gave me the same issue… :sob:


#10

+exec vs. + exec?


#11

YOU DID IT!!! I appreciate all the help guys and gals!